XF 2.2 Reason of a moderative action is missing in the moderator log

rhs

Active member
Hi,

I deleted a post and gave a reason for it. However, this reason is not listed in the moderator log. It simply says ...

Post removed from public view (reason: )

Is there a setting that must be active for this?

It is also not clear to me whether the user even received my reasoning. Can this be traced?

Thanks ...
 

Brogan

XenForo moderator
Staff member
Are you sure you entered a reason?

The only way I can repro that is to delete without a reason.

Try restoring the post and deleting again with a reason.
 

Brogan

XenForo moderator
Staff member
If you have access to the DB you can check the xf_user_alert table to see if anything was sent.

The reason will be in the extra_data blob field.
 
  • Like
Reactions: rhs

rhs

Active member
Note also that the deletion reason and alert reason are separate:
Good catch! So the moderator does not see in the log what he wrote to the user, but only what was commented under "Remove from public view" ...

@Brogan : thanks, in xf_user_alert I can see the hint. Is there a reason why this is not in the log?
 

Jeremy P

XenForo developer
Staff member
Yes, the first field is for the moderator log and the second is for the alert. If you only enter something in one of the fields then the other one will be left blank.
 

rhs

Active member
If you only enter something in one of the fields then the other one will be left blank.
I usually enter something like "OT ..." in the first field and write the more detailed reason for the user in the second field. Only I did not find this in the log in a case where the user thought he had to make stress, hence my question.

My request would be to write both info in the moderator log.
 
Top