• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Ready for PHP7?

Caliburn

Well-known member
#1
I'm not a PHP developer by shot. I do have a question tho. I am probably going to purchase XenForo in the next few months and am wondering if xenForo is prepared to operate under PHP7?
 

Mike

XenForo developer
Staff member
#2
As of yet, it has not been explicitly tested with PHP7. As this is a larger change than PHP 5.3 to 5.4, etc, it wouldn't be surprising to see a few small changes that need to be made (I do know of one that has been made for the next release), but we will aim to support PHP7 at some point.
 

Eagle

Well-known member
#8
Already installed in our server and works fine. Note that PHP 7 are awesome and better than old PHP versions. If anyone have large forum or WordPress in their server, they should switch to PHP 7 version. However, xCache and Joomla! 2.x and 3.x still is not compatible with PHP 7 but don't forget to works great with OpCache.