Read Marking Data Lifetime (Days) - what's yours set to?

AndyB

Well-known member
Now that I better understand this function, I leave it at the default setting of 30 days.
 

Nirjonadda

Well-known member
Now that I better understand this function, I leave it at the default setting of 30 days.
Yes but this option name "Read Marking Data Lifetime" but can not set it "Lifetime" ? Only allowed 1 years so how to call Lifetime?
 

Jeremy P

Well-known member
The lifetime is the value, ie. the lifetime of the read marking data is 365 days (or whatever you set it to). The value of this data decreases over time and the table will grow very large (one row per user per thread visited) if it is not pruned.
 

RSI

Active member
The value of this data decreases over time and the table will grow very large (one row per user per thread visited) if it is not pruned.
So..?

How much larger can the DB get?. What if your webhosting plan has unlimited storage/data? If it gets too large can it slow down your board or something?
.
 

AndyB

Well-known member
Consider that if you have not seen a thread in several months, you will most likely forget what it's about, so going to the first post is helpful so you can understand what the thread is about.
 

RSI

Active member
Well, to quote myself from when I first posted in this thread?
Code:
The reason is when a new member registers, a couple of my forums which have not been posted in over a year are shown as read.

I still think I have a valid point.
.
.
 

Neilski

Member
Where can I force it manually or remove the 365 max limit?
Just had a peek at this.
If you click on the spanner - see first pic (you need to be in debug mode for this to appear),
1518285184595.png
you will get the options shown in the second pic. I haven't tried it yet but I imagine that changing the 365 to something large will do what you need.

1518285268584.png
 

RSI

Active member
Just had a peek at this.
If you click on the spanner - see first pic (you need to be in debug mode for this to appear),
View attachment 168573
you will get the options shown in the second pic. I haven't tried it yet but I imagine that changing the 365 to something large will do what you need.

View attachment 168574
Perfect! That actually worked. Thank You...

It's too bad one of the xenforo people didn't jump in and tell us how to do it after more than one of us asked how.
.
 

Neilski

Member
Perfect! That actually worked. Thank You...

It's too bad one of the xenforo people didn't jump in and tell us how to do it after more than one of us asked how.
.
Happy to help!
And being a noob, I'm not really sure how the support system works but yes I was also surprised that you didn't get a reply (given that the fix was so simple).
 
Top