1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Random MySQLi Error

Discussion in 'XenForo Questions and Support' started by Mike Creuzer, Jan 20, 2014.

  1. Mike Creuzer

    Mike Creuzer Well-Known Member

    Code:
    Mysqli prepare error: Table './smtr_xf/xf_session' is marked as crashed and should be repaired
    
    [LIST=1]
    [*]Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
    [*]Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
    [*]Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
    [*]Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 825
    [*]Zend_Db_Adapter_Abstract->fetchOne() in XenForo/Session.php at line 695
    [*]XenForo_Session->getSessionFromSource() in XenForo/Session.php at line 430
    [*]XenForo_Session->_setup() in XenForo/Session.php at line 414
    [*]XenForo_Session->start() in XenForo/Session.php at line 314
    [*]XenForo_Session::getPublicSession() in XenForo/ControllerAdmin/Login.php at line 7
    [*]XenForo_ControllerAdmin_Login->actionForm() in XenForo/FrontController.php at line 337
    [*]XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    [*]XenForo_FrontController->run() in /home/smtr/public_html/admin.php at line 13
    [/LIST]
    Got this error and no idea how. It just randomly crashed today, did not install anything, edit any files, or anything. Any idea how to fix this?

    Thanks a lot,
    Mike
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    Repair that table using PHP My Adnin.

    It happens. If it continues to happen regularly, consult your host.
     
    Mirovinger and Mike Creuzer like this.
  3. Mike Creuzer

    Mike Creuzer Well-Known Member

    repair table xf_session; did the trick, thanks Chris.
     
    Chris D likes this.
  4. RoldanLT

    RoldanLT Well-Known Member

    I encounter this wayback 2012, and I can say it is a sign of a bad host/mis-configuration on mysql.
     

Share This Page