1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

ragtek Newest Members Sidebarblock

Discussion in 'Add-on Releases [Archive]' started by ajnos, Apr 13, 2011.

Thread Status:
Not open for further replies.
  1. ajnos

    ajnos Member

    This add-on shows the newest valid members in the xenforo sidebar.

    We coded this a while ago for testing our cache components (which aren't included) and for learning coding add-ons, so we didn't thought it's something enybody would be interessted, but let's release it;)

    It doesn't require any template edits.

    Installation:
    • Upload everything from the "upload" directory into your forum directory
    • install ragtek Newest Members Sidebarblock_1.0.2_b_3.xml
    ATTENTION: REQUIRES OUR ADD-ON FRAMEWORK!

    Change History:
    You can now chose where you want to show the sidebar block
     

    Attached Files:

  2. yavuz

    yavuz Well-Known Member

    Can the number of members be increased or the avatars replaced by names ?
    Thanks.
     
  3. ajnos

    ajnos Member

    Yes.
    Open ragtek/nm/static.php

    search for
    PHP:
     array('limit' => 8));
    and replace the8 ;)

    Sorry, i've forgotten that not everybody is a coder.
    I'll add an option for this.

    not with this addon

    It's using the original xenforo template from the members page for the output.
     
    Vodkaholic, ArnyVee and laztrix like this.
  4. Veer

    Veer Well-Known Member

    Nice add-on.

    I got this error:
    Please enter a valid callback method.
     
  5. ajnos

    ajnos Member

    try the newest package

    1. it includes now a option for the user counter
    2. it fixes the bug
     
  6. yavuz

    yavuz Well-Known Member

    Thanks for the fix ajnos, this is being asked a lot these days for sidebar add-ons. Does this add-on work with "The Widget Framework" ?
     
    dieketzer likes this.
  7. Wuebit

    Wuebit Well-Known Member

    As it is right now no
    All lets say "default" addons for the sidebar will not work with (The Widget Framework) They need to be wrote for that also :)
     
    laztrix likes this.
  8. ajnos

    ajnos Member

    Do you know if there is an tutorial/how to for the widgets?
     
  9. yavuz

    yavuz Well-Known Member

    Vodkaholic likes this.
  10. Wuebit

    Wuebit Well-Known Member

    Yup Laztrix is right ;)
     
    laztrix likes this.
  11. dieketzer

    dieketzer Well-Known Member

    in an ideal world all these assorted sideblock addons would have a framework version.
     
  12. ragtek

    ragtek Guest

    I have to disagree.

    1. in an ideal world, xenforo would have a sidebar with own widgets which could be de/activated for every page;)
    2. in an ideal world, people would donate for add-ons:D (even it would be only 1$ :D ) *scnr* now i'm also a beggar
     
    erich37, CFodder and dieketzer like this.
  13. Saeed

    Saeed Well-Known Member

    Umm, is there another addon which I have to add for this to work (some sidebar addon), or this works per se? I ask because after installing, I can't see any "Newest Members" on the forum homepage. :confused:
     
    ragtek likes this.
  14. ragtek

    ragtek Guest

    Do you use an custom style?
    This add-on works without problems with the STANDARD XenForo Style and all custom styles with the xenforo template hooks!
     
  15. Saeed

    Saeed Well-Known Member

    Thank you for responding, ragtek. :)

    Nopes, I'm running it on the default style on a 2 day old installation I am testing. That's what amazes me. I've uploaded all the files, then installed the .xml. Checked the ACP options and changed it to show 2 newest members. But nothing.

    I just reuploaded the folder via FTP and reinstalled the .xml, but no dough.
     
    ragtek likes this.
  16. Veer

    Veer Well-Known Member

    It is not showing anything on my default 1.0.1 style.
     
    ragtek likes this.
  17. ragtek

    ragtek Guest

  18. Saeed

    Saeed Well-Known Member

    I'm running 1.0.1 too.
     
    ragtek likes this.
  19. ragtek

    ragtek Guest

    Saeed likes this.
  20. Saeed

    Saeed Well-Known Member

Thread Status:
Not open for further replies.

Share This Page