• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.
  • This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

ragtek BBCode Sidebar Block

R

ragtek

Guest
#1
This add-on adds an bb-code sidebar block to your xenforo.

In ACP => options => sidebar blocks you'll find 3 new options:
HTML Block Position, blocktitle, HTML Code (they are self explanatory ^^)
bbcode.PNG
BUT
you're also able to change the content in the frontend!
editfront.PNG

Your Admins will see a icon right to the Block Title.
If they click this AND IF THEY HAVE PERMISSIONS TO EDIT THE OPTIONS, a inline editor will be shown.
htmlblockeditor.PNG

ATTENTION: This add-on requires this add-on: http://xenforo.com/community/threads/ragtek-add-ons-helper-framework.15163/ !

donations are welcome and get a special gift;)
paypal
 

Attachments

Staxed

Active member
#2
Curious, in the screenshots you've shown, your HTML bolds part of the text, but in the image of the block it isn't actually bolded. Was going to install this until I noticed that. Is it not actually parsing all of the html, or did you just take the screenshot before you actually put in the bolded part?
 
R

ragtek

Guest
#3
Curious, in the screenshots you've shown, your HTML bolds part of the text, but in the image of the block it isn't actually bolded. Was going to install this until I noticed that. Is it not actually parsing all of the html, or did you just take the screenshot before you actually put in the bolded part?
thx
yes there was something strange in the version released here.

I've added the bb code block with inline editor to the first post (which is working^^):)
 

Staxed

Active member
#4
thx
yes there was something strange in the version released here.

I've added the bb code block with inline editor to the first post (which is working^^):)
are you going to work on another html version? I was looking forward to this because I want an html block, not a bbcode block :D (was going to use it to display ads from my adserver, which won't work with bbcode). I guess I'll just putter around and make a manual template like I was going to do if you aren't going to get the html block working.

Probably use this though as I have another block idea that would probably work well with bbcode though, so thanks :D
 

DroidHost

Well-known member
#5
Hi ... great coding
I have to ask u if u could post a tutorial to explain the cods that u use in this addon as it is simple and -as I think- not complected
-how to have options in ACP
.... etc
thanks :whistle:
 
R

ragtek

Guest
#6
are you going to work on another html version? I was looking forward to this because I want an html block, not a bbcode block :D (was going to use it to display ads from my adserver, which won't work with bbcode). I guess I'll just putter around and make a manual template like I was going to do if you aren't going to get the html block working.

Probably use this though as I have another block idea that would probably work well with bbcode though, so thanks :D
ah, mom, i'll code a fast one:D ( the problem is, that ajnos & i hadn't talked about this add-on and both made changes to this one, instead of creating a new one,... that's why the html add-on was destroyed...)
 

Staxed

Active member
#8
ah, mom, i'll code a fast one:D ( the problem is, that ajnos & i hadn't talked about this add-on and both made changes to this one, instead of creating a new one,... that's why the html add-on was destroyed...)
lol, gotcha...i did that the other night when I was messing with something at 3am...except I didn't talk to myself and messed something up :)
 

karoshio

Active member
#13
Okay, thanks a lot. Is it impossible to get the Latest Posts Sidebar Block 1.1 without upgrading my account on your website?(Thought ask here whilst replying.)

 

zaiger

Active member
#19
I have been trying to install this for over an hour now so maybe someone can help me. I have uploaded the contents of the upload file to my ~/library/ragtek/ folder like always, but when I go to upload the XML I get this error:
Error

The files associated with this add-on could not be found. Please upload them and try again.
Usually when I get that error I just put the XML file on the server and load it from there but that isn't working either, anyone have another solution to this? I'm still on 1.0.4 by the way.