1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Quotes are being replaced

Discussion in 'Troubleshooting and Problems' started by Antiferna, Aug 30, 2013.

  1. Antiferna

    Antiferna Member

    Hi all. I'm having a little problem since i updated to 1.2.
    All the quotes that i write in posts's texts are replaced like this:

    "This is an example".

    Is replaced by:

    \"This is an example\".

    The same happens with single quotes, in posts content and in the configuration text boxes in admin panel too. I don't have any idea of what can be the problem. Hope you can help me, because all the texts, including template links are being affected by this.
    Sorry for my bad english.
  2. Daniel Hood

    Daniel Hood Well-Known Member

    Can you post a screenshot of all the addons you have installed? I know this doesn't happen by default so it's most likely an addon or if you made any modifications to the bbcode parser?
  3. Antiferna

    Antiferna Member

    Here is the screenshot. Thanks for the fast reply.

  4. Daniel Hood

    Daniel Hood Well-Known Member

    Would you be open to quickly disabling all of these and making a post using quotes? if it adds the slashes then you know it's your forum install. If it doesn't, go back to the list -> enable -> make post with quotes -> continue downward until you get slashes again. I can't single one addon out of that list because the ones I know hook into the bbcode nobody else had issues with and I don't know the others.

    What I suggested is a sure fire way to find out which addon is at fault though.
  5. Antiferna

    Antiferna Member

    I disabled all addons and i still having the problem, so something happened with my xenforo. It's really weird.
  6. Daniel Hood

    Daniel Hood Well-Known Member

    Did you run the requirements script on your server before installing?
  7. Antiferna

    Antiferna Member

    I installed Xenforo like 1 year ago with all requirements ok. With 1.1.x i had no problems, but now i re-ran the test and it's telling me that safe_mode is enabled. I'm sure tha it's disabled, however i'll contact my host support to try to solve that problem.

    Can be that the cause of my problem?

    EDIT: After re-disabling safe mode problem was solved.

    Thank you so much!
  8. Daniel Hood

    Daniel Hood Well-Known Member

    No problem. Sorry I stopped being responsive. I was on my way home. Glad your issues solved.

Share This Page