1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Question about ImageMagick pecl extension

Discussion in 'Troubleshooting and Problems' started by Cylent1, Feb 28, 2016.

  1. Cylent1

    Cylent1 Active Member

    If I already have xenforo installed on a hosted server, and had imagemagick installed after, it should still work right?
    Cause I cannot click the radio button for it and they installed that for me.
  2. whynot

    whynot Well-Known Member

    With ImageMagick pecl extension installed-enabled you should be able to see the .gif images in your forum.
    I don't know what radio button are you looking for?
  3. Martok

    Martok Well-Known Member

    Are you sure that it is definitely installed?

    Check yoursite.com/admin.php?tools/phpinfo and see if Imagick is listed and what version it is.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Has the imagick PHP PECL extension been installed and compiled against the ImageMagick libraries on the server?
    Both need to be installed.
  5. Tracy Perry

    Tracy Perry Well-Known Member

    And in addition to being installed, normally the PHP processor needs to be restarted (in the use of Apache by restarting it, in nginx by restarting the php-fpm process).
  6. Cylent1

    Cylent1 Active Member

    SOLVED! Thanx Guys...
  7. Martok

    Martok Well-Known Member

    And the problem was...?
  8. Cylent1

    Cylent1 Active Member

    My site did not fully propogate yet! I was still looking at the old site. SMH...
  9. viper357

    viper357 Active Member

    How do I check if I have the PECL extension installed? Can you tell from this screen?

    screenshot 2016-04-20 19-43-43.jpg
  10. Martok

    Martok Well-Known Member

    That shows you have it installed.
    viper357 likes this.
  11. viper357

    viper357 Active Member

    Thank you.

Share This Page