• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Problems after import

estranged

Well-known member
#1
I have finally converted my phpbb2 forum to xenforo (90.000+ users 700.000+ posts) Converted to vbulletin first. It was a pain. It took too long, server load was very high during the convert and I had to refresh the page many times. But converting from vbulletin to xenforo was smooth. I was surprised to see server load did not change during the import and I also did not have to refresh the page.

However I have some issues after the import. Of course I was not expecting an import with zero problems.

  • Some users titles are "Guest" They are registered users but user title is Guest. I checked the database, they belong to registered users ID (2) but their styling display_style_group_id is 1
  • I have one user who says his nickname is changed to somebody elses nickname. This is very strange.
There are a few more issues which I forgot now, but I will update the thread when I remember :)

Finally, this is not an installation issue but, users can edit their posts but they can't edit their thread title. How can I fix this? I checked permissions but couldn't find it. Users have gone mad.
 

Brogan

XenForo moderator
Staff member
#2
Are those users also members of another imported group (Guest) which has a higher display styling priority?

By nickname do you mean user name?
Is it possible that happened during the phpBB to vB import?

Did you do any cleaning up of the vB database after importing from phpBB?
There's a thread here which mention some of the things you can do to sanitise the data: http://xenforo.com/community/thread...etin-3-8-to-xenforo-what-to-do-exactly.13486/

Thread titles can only be edited by moderators currently.
 

estranged

Well-known member
#3
Are those users also members of another imported group (Guest) which has a higher display styling priority?
No, they don't belong to another group. They only belong to group ID 2 which is for registered users but their display_style_group_id is 1 which is for guests.

By nickname do you mean user name?
Yes :D

Is it possible that happened during the phpBB to vB import?
May be. Not sure. Will check now.

Did you do any cleaning up of the vB database after importing from phpBB?
There's a thread here which mention some of the things you can do to sanitise the data: http://xenforo.com/community/thread...etin-3-8-to-xenforo-what-to-do-exactly.13486/
I made some cleaning in phpbb. Didn't do anything on vb. Just installed a clean vbulletin and did the import. Then started importing to xenforo without doing anything on vb

Thread titles can only be edited by moderators currently.
This is very very very bad! I have one spesific forum this is needed. Guess I need to open a feature request thread.
 

estranged

Well-known member
#4
I've got the details of the username issue from the user:

This user tries to login to his account but gets the error "user not found"

Thinking his account is deleted, he tries to register again.

This time he gets the error: "email is already in use"

Then he requests a password reset. He receives the mail but the instructions are for another username.

Looks like email is associated with another username somehow :confused:
 

Brogan

XenForo moderator
Staff member
#5
When importing into XenForo, you are given the option of what to do with duplicate user name or email addresses.
See here: http://xenforo.com/help/importing/

Did you see anything related to that?
If not then it's more than likely the merge was done when you imported from phpBB to vB.

For the guest user problem, you could run an SQL query to change the display styling priority?
UPDATE xf_user SET display_style_group_id = 2 WHERE display_style_group_id = 1
Take a backup first!

There may however be other related issues if they weren't imported correctly; permissions, etc.

A suggestion has already been made for editing thread titles: http://xenforo.com/community/threads/suggestion-edit-thread-title.5691/
 

estranged

Well-known member
#6
I didn't have any errors or messages during xenforo import. But impex was giving errors like "invalid email skipping"

I checked the usertable for the problematic users, their email looked normal. I couldn't find any problem. So I have no idea why impex gave those errors.

This user has no idea about his new username. How can they be duplicate?

Thanks for the sql command Brogan
 

Brogan

XenForo moderator
Staff member
#7
I didn't have any errors or messages during xenforo import. But Impex was giving errors like "invalid email skipping"
Sounds to me like the issue was during the first import then.
You can actually edit the Impex config file to see more detail on errors, if I remember correctly.

This user has no idea about his new username. How can they be duplicate?
Well if the users have been merged then that user will no longer exist.
Check in the vB imported installation to see if you can find both users.