1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem with non-Latin charachter

Discussion in 'Installation, Upgrade, and Import Support' started by puppi, May 25, 2013.

  1. puppi

    puppi New Member

    I have used vB4 Importer 3.6b2 to import users from a Persian VB4.2 forum. All seems to be fine expect that all non-Latin characters are turned into ???? symbols.

    Also, another language specific problem that might be relevant:
    I imported this Persian Language pack to the freshly installed XF 1.1.5 but none of the Persian string show up when I set default language to Persian.

    I really appreciate your hints to solve these.
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. puppi

    puppi New Member

    Here are the result from the myxfdb:

    I went through the topic that you linked but could not figure out how they solved the problem. Greatly appreciate if you could elaborate on this.
    Also, I'm wondering why the language table has not been created?
  4. Brogan

    Brogan XenForo Moderator Staff Member

    The collation is latin1_swedish_ci instead of utf8, so you could try that.

    The language table is created on initial XenForo install so that would indicate a problem with original XF build.
  5. puppi

    puppi New Member

    Well looked inside the myxfdb and I see that xn_language actually exists. Here is the description:

  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    There is confusion here between vB's language table and XF's language table. Run this query on your vB database:

    SELECT charset FROM language;
  7. puppi

    puppi New Member

    Here it is Jake:

  8. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Try setting Force Character Set to "latin1" when running the import.
  9. puppi

    puppi New Member

    Ok, I'll try to force 'latin1' next time and let you know the result. Thanks

Share This Page