• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Problem with my Image Proxy

#1
Hello, I activated the Image Proxy. I tried to put an IP Logger (allows to know the IP address without it) in an image iplogger.com [/ IMG] and it did not work, the Image Proxy blocked that. Except that I tried to edit the message with IP Logger and that is when my IP is displayed. The worry is that when an Administrator edit a message with an IP Logger Image Proxy protection no longer works. What to do ?

Yours
 

Mike

XenForo developer
Staff member
#2
Images are not proxied when edited/inserted. This is expected. The behavior you're expecting isn't really the primary purpose of the proxy (which is mostly to allow HTTPS to be used without causing issues), so it's not something that can be guaranteed.
 
#3
How to completely remove IPLogger from Xenforo because you can have the IP of my host and my IP? Thanks in advance.
 
Last edited by a moderator:

Mike

XenForo developer
Staff member
#4
I'm not sure what you're asking. Any connection will require an IP address, so the only way to prevent someone from getting your IP is to block any outgoing connections (or to push everything through a proxy).
 

Mike

XenForo developer
Staff member
#6
From your server? Don't use the image proxy or any feature that requires your server to contact an external URL that you don't trust.

You likely need to watch how you send mail as that would likely have your server contacting an external one. Even going through a trusted SMTP server may leave logs in the mail from that server.