1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 private staff forum gives me headaches (rights)

Discussion in 'Troubleshooting and Problems' started by RalleRalle, Mar 24, 2015.

  1. RalleRalle

    RalleRalle Member


    like I guess all of you I also have a staff-forum, a forum only for my moderators.
    My problem: Every posts the moderators write in the staff-forum land in the moderating queue and have to be moderated.

    What I did:
    I set that forum node to "private" and the "new threads / posts have to be moderated" set to "off"(!).
    All moderators have the primary usergroup "Moderating". I set all the ordinary user rights of that usergroup for the staff-forum-node to "Yes".

    When I use the "analyze rights" and test the node with a name of one of my moderators it gives me all green lights like:
    Can post new Threads: Yes
    Can post new Posts: Yes

    So far all as expected. (They can see and enter the staff forum and post.)

    Where can I search?
    Thank you!
  2. Sunka

    Sunka Well-Known Member

    Check what option for "Follow message moderation rules" you set for Moderators usergroup
  3. Brogan

    Brogan XenForo Moderator Staff Member

    Creating a private forum is just two steps.

    There are two ways of doing it.

    1. Set the node as private
    2. Allow the 'View node' permission for the desired user group(s) or user(s).


    1. Revoke the 'View node' permission for the Registered user group
    2. Allow the 'View node' permission for the desired user group(s) or user(s).
  4. Martok

    Martok Well-Known Member

  5. RalleRalle

    RalleRalle Member

    @Brogan the moderators can see the staff forum. They also post in there. but the posts have to moderated - that is my problem.

    @Sunka uff, I can't find the "follow message moderation rules" option in the usergroup settings. Is it named exactly like that? (I also can't find a phrase like that)
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Undo whatever other changes you have made and just implement those two steps.

    Also, as @Martok has posted above, you don't have the user groups set up correctly.
  7. RalleRalle

    RalleRalle Member

    @Martok thanks. I'll try that. Even though I don't see why this should change anything, as the "analyze" feature gave me clear "yes". OK, I'll let you know if that helped.
  8. Martok

    Martok Well-Known Member

    It may or may not change anything regarding this issue. However it makes life a lot simpler and can help to avoid permission issues by setting things in the recommended way.
  9. RalleRalle

    RalleRalle Member

    Yepp. It works now.
    Until today I thought I understood the xenforo rights system. Well, I didn't.

    Thank you!

Share This Page