1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Private Messages and Email

Discussion in 'XenForo Questions and Support' started by Dav, Nov 26, 2010.

  1. Dav

    Dav Active Member


    I was just wondering if there was a way to disable private conversations or is there a way to moderate or view them for ones which members send?.

    Also when you send a email to your members can you select which members it goes to. Iv tried to send emails to selected members but cant seem to find the option. It seems to send to every member when i send the email.

  2. Brogan

    Brogan XenForo Moderator Staff Member

    You can set personal converstaion permissions per user group.
    So you can allow some groups to start them and others not.


    Individually, members can stop other members from starting PCs with them by setting their privacy preferences to people they follow only:

    With regards to sending email, doesn't entering the usernames in the field achieve that?
    I just tested it by entering 3 users and it indicated that the list of recipients would be just those 3.
    Nix and Jake Bunce like this.
  3. Jamie

    Jamie Well-Known Member


    I am haven't an issue with my PC's and permissions and I want to check to make sure I understand them correctly.

    I have a Registered group with the settings like this:

    • Start personal conversations: Allow
    • Maximum conversation recipients: 5
    • Edit own messages: Allow
    • Time limit on editing own messages (minutes): 3
    When I click on a member in the Registered group (I don't have any Secondary groups set) and look at their permissions I see this:

    • Start personal conversations: Default
    • Maximum conversation recipients: Default
    • Edit own messages: Default
    • Time limit on editing own messages (minutes): Default
    This member can only seem to see the Start a new conversation with the Admin and Mods of the site. He can't see that link with other Registered members.

    I thought that the user permission of default would refer to the Registered Groups permissions which is set to allow

    Looking at this post from Jake it would seem that he should be able to start a conversation, but I think I am misunderstanding it since he can't.

    Both the usergroup AND the user permissions don't need to be set to Allow do they?

  4. Brogan

    Brogan XenForo Moderator Staff Member

    No, as long as the usergroup permissions are set to allow and the member is in the user group then he will be able to start/send PCs.

    That is as long as there are no other permissions which override the allow (e.g. a deny) set either individually or in another user group the member is in.

    The permissions show as default when viewing the individual user as you haven't set any user specific permissions for them, so they default to the group(s) they are in.
  5. Jamie

    Jamie Well-Known Member

    OK, well I thought that was how it should be, now I need to dive in and find out why or what is causing it to be denied.

  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Hmm. I'm gonna guess this is because those other Registered members have their user preference set to restrict who can contact them. You can see those user prefs here on this forum:


    Screen shot 2010-11-26 at 3.43.30 PM.png

    If you want to set that preference for all users then you can run this query on your database:

    UPDATE xf_user_privacy
    SET allow_send_personal_conversation = 'everyone'
    edit - I see Brogan actually pointed out this user preference in a previous post. But the query will probably be useful for you.
  7. Jamie

    Jamie Well-Known Member

    hey Jake and others that may have this problem..

    The table did need to be updated. When I imported the forums everyone was set to none, which meant no one could start a conversation. Running that SQL update fixed the problem. I was going crazy because I thought things were set right, but couldn't figure out why they couldn't start a PC..

    Now, I wonder if it's a bug in the importer or just a fluke with mine...

    Thanks for the help!

  8. Brogan

    Brogan XenForo Moderator Staff Member

    Good to know, thanks for the feedback Jamie.

    Which importer did you use; 3 or 4?
  9. Jamie

    Jamie Well-Known Member

    My site was running IPB 3.1.2 so I went from IPB 3.1.2 > vB 3.8 > xF using Impex

    Since no one else seems to have this problem, I would guess that going from one script to another to yet another caused the problem but I don't know..

  10. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Yep, that is a limitation of ImpEx. ImpEx doesn't do user prefs. You would have lost those prefs going from IPB to vB.

    xenForo's importer actually does preserve those user prefs. I just ran a user import and confirmed that all imported users were given appropriate PM preferences.

    In your case you can either fix the prefs in vB following the first import, or you can fix the prefs in xenForo by running queries. Because xenForo doesn't yet have a utility to manage user prefs I recommend fixing those prefs in vB:

    Admin CP -> Maintenance -> Execute SQL Query

    Screen shot 2010-11-26 at 7.42.26 PM.png
    FreshFroot and Brogan like this.
  11. Jamie

    Jamie Well-Known Member

    Thanks! I have already made the switch with my live site, so going back to vB to set preferences isn't an option at this point. :)

    I will have to look at the member preferences and see what they are set at now, and go to phpMyAdmin and see what needs to be changed for the 'default'

    Thanks again for the help!

  12. Brogan

    Brogan XenForo Moderator Staff Member

    Good to know, thanks guys.

    I will more than likely be going phpBB -> Vb 3.8 -> XF so it's possible that I will encounter similar problems.
  13. Jamie

    Jamie Well-Known Member

    Well for reference, so far I did look at the other columns in this table and only two of them was set 'correctly' (everyone) so I updated them all.

    • allow_view_profile was set to everyone
    • allow_post_profile was set to no
    • allow_send_personal_conversation was set to no
    • allow_view_identities was set to no
    • allow_receive_news_feed was set to everyone

  14. Dav

    Dav Active Member

    Thanks for your help brogan :)
  15. steven s

    steven s Well-Known Member

    On these same lines, I don't see where I can limit the number of PCs a user can have.
    In post #2 where it says default. What are the default values?
  16. Brogan

    Brogan XenForo Moderator Staff Member

    The default refers to being able to start personal conversations and as far as the permissions system is concerned, default means no.

    There is currently no limit on how many PCs a user can have in their in box.
  17. steven s

    steven s Well-Known Member

    Well that's not good. :(
    I was hoping to give site supporters 1000 PCs.
  18. FreshFroot

    FreshFroot Well-Known Member

    Thanks for the heads up.

    And wow.. how sad is this. Using vB for such a long time and I never ONCE used the execute SQL Query command :p

    Learn something new everyday!

Share This Page