1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. This forum has been archived. New threads and replies may not be made. All add-ons/resources that are active should be migrated to the Resource Manager. See this thread for more information.

Prevent guests/users from using proxies at your forum

Discussion in 'Add-on Releases [Archive]' started by borbole, Mar 30, 2011.

Thread Status:
Not open for further replies.
  1. borbole

    borbole Well-Known Member

    This hack will allow you to prevent guests/users from using proxies at your forum. You can dissallow proxies for the forum as a whole or to prevent only registrations with proxies. You can enable and disable it at the Acp of your forum where you can control the settings for the mod.

    Note: As you know there is no such way of preventing proxies 100% but it helps a lot. I tested it with a dozen proxies and it stopped 8 of them.

    Note: This mod blocks ports 80 and 443 which are regular open proxy ports. And if the IP address of the computer is coming from computer that has those ports open means that the user is behind a proxy. So if you have users who use those ports then this mod will block them too.

    Download link and support:

    http://www.forumservices.eu/index.p...ts-users-from-using-proxies-at-your-forum.20/

    To the staff: I have seen some threads here where coders/designers place the products at their forums for the download. So I assumed that this is allowed. In case I am mistaken in my assumption, I appologize and you can remove the thread.
     

    Attached Files:

    Andrew, turtile and gordy like this.
  2. gordy

    gordy Well-Known Member

    An admin option to specify different ports, comma delimited and/or range would be cool!
     
    borbole likes this.
  3. borbole

    borbole Well-Known Member

    This was a quick conversion of my same mod for vb. Later on, when I will have some free time, I will look into expanding the mod.
     
  4. Andrew

    Andrew Well-Known Member



    Thats what I get when I try and install. :confused:
     
  5. Nasr

    Nasr Well-Known Member

    You need to upload the files first to the correct directory. Then after the files are uploaded, upload the xml file..
     
    borbole likes this.
  6. borbole

    borbole Well-Known Member

    As mentioned above that is the cause of thee error you got. But if you will need further help with this, please post at its thread at my forum as I support my mods there :)
     
  7. MrChris

    MrChris Member

    links broken .. looks like a a great plugin
     
    borbole likes this.
  8. borbole

    borbole Well-Known Member

    Fixed. Thanks for bringing this to my attention :)
     
    a legacy reborn likes this.
  9. Hyperion

    Hyperion Active Member

    Unfortunately felt compelled to remove this since a person I know well who registered was blocked by this before I disabled it. He was not behind a proxy. I was thinking there may be false positives, but with the first registration after I applied this made me worried.
     
  10. mrGTB

    mrGTB Well-Known Member

    You can't stop some free proxy services from what I've seen. Try stopping people using: HideMyAss. Could be wrong, but that and another one I know of seem impossible to block users getting in with.
     
  11. eviltechie

    eviltechie New Member

    Could have been someone who uses remote control software like TeamViewer. The default port TeamViewer runs on is 80...I believe because most routers have that open be default.
     
Thread Status:
Not open for further replies.

Share This Page