• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Fixed  Posting via the Wii: editor areas can not receive focus

Rudy

Well-known member
#1
This is probably the winner of today's "Most Useless Bug Report Ever™."

For kicks, I was trying my XF forum last night via my Wii, which uses a custom version of the Opera browser. Navigating the forum works OK, even if the links are a bit small. But, I could not reply to posts--I could not get focus over to the editor window, no matter what I did. "Typing" on the Wii is a pain, as you do it from a screen-based keyboard; this activates when you focus on any text area (an <input> or <textarea> in a form in other words).

As I mention in the title, the market for XF usage on the Wii is probably one person (me) in billions (the world population), so I wouldn't urge anyone jump on fixing this one. But thought I'd make you aware of it anyway. I'm willing to be the test guinea pig if you should decide to look into this.
 

Rudy

Well-known member
#2
BTW, I do have a Nintendo DS, and have access to a DSi if any testing needs to be done in those devices as well. (Although for the DS/DSi and even the Wii, I often try to use a site's mobile theme instead, just for readability.) They also use Opera. The DS needs a game cartridge, where the brower is downloaded into the DSi via the Nintendo site.)
 

Rudy

Well-known member
#5
Or just disable the editor if the Wii is browsing like they do for mobile devices.
I've never checked to see what the user agent string is for the Wii. I feel a mobile view would be better targeted for the Wii, as the resolution of your basic television isn't that good.
 

Mike

XenForo developer
Staff member
#8
Disabled the WYSIWYG editor for Opera 8 and 9, which covers the Nintendo DS as well from what I can see.
 

Rudy

Well-known member
#9
I'll try it out later--I bet it will work fine now. I have to re-sync Wii remotes since my daughter mistakenly took the wrong one home this past weekend.

Thanks Mike!