1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PostID in URL ???

Discussion in 'XenForo Questions and Support' started by masterchief, Feb 27, 2014.

  1. masterchief

    masterchief Well-Known Member

  2. Brogan

    Brogan XenForo Moderator Staff Member

    That happens automatically for any post which isn't the first one in the thread.
  3. masterchief

    masterchief Well-Known Member

    good morning.. thanx . The postID shows up in the permalink, but nothing is ever displayed in the navigation toolbar as part of the URL such as post #1 in this thread

    I guess what I am wanting is for the post tag to become part of the URL in the navigation toolbar
  4. Brogan

    Brogan XenForo Moderator Staff Member

  5. masterchief

    masterchief Well-Known Member

    perfect! good to know. option number two is what is being displayed in the navigation toolbar for my web browser. that is what I want to happen on my system too.

    This is the structure that is posted on my system:


    it seems incomplete ????? is this an option selectable by the admin?

    UPDATE: Is this an htaccess customization issue
    Last edited: Feb 27, 2014
  6. masterchief

    masterchief Well-Known Member

    If you follow the link the postID anchor displays as part of the URL in the navigation toolbar...

    If you visit that same post from the forumhome listing it is being displayed quite differently, as postID anchor is dropped.


    what is happening here? why are two entirely different URL being displayed in navigation toolbar??
  7. Divvens

    Divvens Well-Known Member

    Exactly where from forum-home are you clicking that link that drops the postID?
  8. Brogan

    Brogan XenForo Moderator Staff Member

    It doesn't matter that the post ID is not part of the URL.
    The same post is still displayed/anchored.
  9. masterchief

    masterchief Well-Known Member

    This is what is displayed in my browser navigation toolbar right now for this thread: http://xenforo.com/community/threads/postid-in-url.69455/#post-726846

    My simple question to you, 'How can I accomplish the same thing to happen on my forum threads and posts?'
    You are now making me feel that something is wrong with me asking....

    I do not understand this so where do I discuss this:

    The URL for the first post in this thread is all of the following:

    I would like to have the URL in the second option displayed and I am just asking how to do that
  10. Brogan

    Brogan XenForo Moderator Staff Member

    As I already stated, it does it automatically.

    What is a link to a post on your forum which isn't doing it?
  11. masterchief

    masterchief Well-Known Member

  12. Brogan

    Brogan XenForo Moderator Staff Member

  13. masterchief

    masterchief Well-Known Member

  14. Brogan

    Brogan XenForo Moderator Staff Member

    I have no idea what it is you are actually asking then.

Share This Page