1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Post, PMs and ACP not working

Discussion in 'Troubleshooting and Problems' started by jsmith389, Nov 13, 2014.

  1. jsmith389

    jsmith389 Member

    I appoligize if this is in the wrong forum. I have been using Xenforo for more than a year with no problesm but today all of the sudden

    when users are posting it doesnt show up until and hour after and PMs are doing the same.
    I also can not use the ACP it says logging in and then returns to the login screen again. I have tried everything I could find on here. Doing a .htacces, clearing my cookies, and Iam not sure if this is a cache problem because there is no option for it in the .config file in library.
  2. Amaury

    Amaury Well-Known Member

    Disable all add-ons and try again. If the issue goes away, re-enable the add-ons individually to find the culprit.
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Several customers are reporting similar problems this evening. All appear to be nginx servers with Hostgator. Please contact Hostgator about this. These are the response headers that I have observed:

    Content-Type:text/html; charset=UTF-8
    Date:Thu, 13 Nov 2014 06:54:45 GMT
    Expires:Fri, 14 Nov 2014 06:54:45 GMT
    Last-Modified:Thu, 13 Nov 2014 06:54:45 GMT
    This is generated by a PHP resource which should not be cached.
  4. billytimmy

    billytimmy Member

    for anyone else suffering from this hostgator change I fixed this by adding this to .htaccess

    <IfModule mod_headers.c>
    Header set Cache-Control "no-cache, no-store, must-revalidate"
    Header set Pragma "no-cache"
    Header set Expires 0
    Jake Bunce and jsmith389 like this.
  5. jsmith389

    jsmith389 Member

    Thanks This seems to have worked for me!
  6. Dodgeboard

    Dodgeboard Well-Known Member

    Yep - having the same issue here as well, on Hostgator
  7. Dodgeboard

    Dodgeboard Well-Known Member

    This fixed my problem as well. Thank YOU JAKE, billytimmy & Jsmith!!

Share This Page