• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Post, PMs and ACP not working

#1
I appoligize if this is in the wrong forum. I have been using Xenforo for more than a year with no problesm but today all of the sudden

when users are posting it doesnt show up until and hour after and PMs are doing the same.
I also can not use the ACP it says logging in and then returns to the login screen again. I have tried everything I could find on here. Doing a .htacces, clearing my cookies, and Iam not sure if this is a cache problem because there is no option for it in the .config file in library.
 

Amaury

Well-known member
#2
Disable all add-ons and try again. If the issue goes away, re-enable the add-ons individually to find the culprit.
 

Jake Bunce

XenForo moderator
Staff member
#3
Several customers are reporting similar problems this evening. All appear to be nginx servers with Hostgator. Please contact Hostgator about this. These are the response headers that I have observed:

Code:
Cache-control:max-age=86400
Connection:keep-alive
Content-Encoding:gzip
Content-Length:3770
Content-Type:text/html; charset=UTF-8
Date:Thu, 13 Nov 2014 06:54:45 GMT
Expires:Fri, 14 Nov 2014 06:54:45 GMT
Last-Modified:Thu, 13 Nov 2014 06:54:45 GMT
Server:nginx/1.6.2
Vary:Accept-Encoding
X-Frame-Options:SAMEORIGIN
This is generated by a PHP resource which should not be cached.
 
#4
for anyone else suffering from this hostgator change I fixed this by adding this to .htaccess

<IfModule mod_headers.c>
Header set Cache-Control "no-cache, no-store, must-revalidate"
Header set Pragma "no-cache"
Header set Expires 0
</IfModule>
 
#5
for anyone else suffering from this hostgator change I fixed this by adding this to .htaccess

<IfModule mod_headers.c>
Header set Cache-Control "no-cache, no-store, must-revalidate"
Header set Pragma "no-cache"
Header set Expires 0
</IfModule>
Thanks This seems to have worked for me!