Post Guard Pro

Post Guard Pro [Paid] 1.0.3

No permission to buy ($15.00)

Yugensoft

Well-known member
#1
Yugensoft submitted a new resource:

Post Guard Pro - Prevent users posting invalid or disallowed content with Post Guards

Description

Post Guard Pro allows you to block invalid or disallowed content submissions using "Post Guards". If a user attempts to submit a prohibited form of content, it will fail and they will receive an error message that you specify for that post guard.

It is highly customizable.

Features
  • Wide selection of commonly used Post Guards.
    • Minimum length
    • Uncapitalized first letter
    • Only quote
    • Words
    • Strings
    • Characters...
Read more about this resource...
 
#2
Add options for the guard types.

Such as for the external links guard, allow the setting of domains to be ignored.

Seems on XF 1.5.14 the extended options per guard type aren't appearing therefore causing guards such as words and characters to not be useable.
 
Last edited:

Yugensoft

Well-known member
#3
Add options for the guard types.

Such as for the external links guard, allow the setting of domains to be ignored.

Seems on XF 1.5.14 the extended options per guard type aren't appearing therefore causing guards such as words and characters to not be useable.
OK I'll take a look at it today on that version.
 

Yugensoft

Well-known member
#4
Seems on XF 1.5.14 the extended options per guard type aren't appearing therefore causing guards such as words and characters to not be useable.
I'm having difficulty replicating this. Could you tell me the actions that lead up to the options not showing?
 
#6
Hello, I have XenForo 1.5.15 and whn I try install the "Post Guard Pro", I obtain this errors:




What is the problem?.


Thanks.
 

Yugensoft

Well-known member
#9
Do you know what version of MySQL your server is running?
If it's below 5.7.8, it appears it doesn't support JSON datatypes, in which case I'll have to modify this add-on to support older versions.
 
Last edited:
#10
Do you know what version of MySQL your server is running?
If it's below 5.7.8, it appears it doesn't support JSON datatypes, in which case I'll have to modify this add-on to support older versions.
I'm runing in 5.4.16 :(. How could I use it for my version?.


Thanks.
 

Yugensoft

Well-known member
#11
How could I use it for my version?.
I'll make an update to accommodate you; but it won't transfer across any post guards from the Post Guard (basic) add-on if you were using that before.

But heads up that the XenForo System Requirements say to use MySQL 5.5+, so if you try to upgrade to XenForo 2 in the future it might not work, so you might want to upgrade your MySQL anyway.
 
Last edited:
#12
I'll make an update to accommodate you; but it won't transfer across any post guards from the Post Guard (basic) add-on if you were using that before.

But heads up that the XenForo System Requirements say to use MySQL 5.5+, so if you try to upgrade to XenForo 2 in the future it might not work, so you might want to upgrade your MySQL anyway.
Where can I download the new version ?. Today I bought it through your website :).
 
#14
It's live now, if you download again it should be version 1.0.2. Let me know if it works OK.
The install works good but when I try to manage it, i obtain this error:

Parse error: syntax error, unexpected '(' in C:\xampp\htdocs\website\library\PostGuardPro\Helpers.php on line 12
 
Top