[WMTech] Post Guard (basic)

[WMTech] Post Guard (basic) 2.0.0

No permission to download

Yugensoft

Well-known member
Yugensoft submitted a new resource:

Post Guard - Prevent users posting invalid posts & threads with regex post guards.

Introduction
XenForo prevents users from creating posts with no content. However there may be other types of invalid posts that you wish to prevent.

Description
This add-on allows you to specify invalid posts using regular expressions, or "post guards". If a user attempts to submit a post which matches one of your post guards, it will fail and they will receive an error message that you specify for that post guard. You can also set guards for thread titles...

Read more about this resource...
 

Andrej

Well-known member
Can "post guards" apply only to certain user groups, or is it global only? Example use case would be blocking posts which contain an external URL for users belonging to X user group. At the same time it is the only use case I can think of right now for that, so if it is not included, it makes sense.
 

Yugensoft

Well-known member
Can "post guards" apply only to certain user groups, or is it global only? Example use case would be blocking posts which contain an external URL for users belonging to X user group. At the same time it is the only use case I can think of right now for that, so if it is not included, it makes sense.

It's currently completely global, but I've had a couple of requests to make it more customizable. If I get any more I'll potentially make a "post guard pro" version.
 

metohu

Member
@Yugensoft
Report an error:
Regex input box has a 101 character limit, my long regex can't be completely pasted.

Other question: Any ETA for Post Guard Pro 2.0?
 

wmtech

Well-known member
This resource has been removed and is no longer available.

We will start selling XF2 products in 2020. This product will be updated and available soon.
 

Alpha1

Well-known member
I'm running Post Guard Pro on XF1. Will this addon be updated to XF2? If not then is it possible to upgrade the xf1 pro version to the xf2 basic version?
Does this work on the latest version of XF?
 

wmtech

Well-known member
Post Guard Pro is not available for XF2.

You can upgrade Post Guard Basic to XF2 with the XF2 version.
 
Top