1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Possible profile corruption?

Discussion in 'XenForo Questions and Support' started by Glockie, Nov 18, 2015.

  1. Glockie

    Glockie Well-Known Member

    Hi all,
    Am just wondering if it is possible for a profile to become corrupt and if so, how to repair it?
    I have a member who has several usergroups and has been overall quite active, but another member recently had some issues with them and ignored them and blocked them.

    Trouble is they can still see some comments and posts. So I switched off a few things and did my own testing, and I can block everyone and posts will not appear and any relevant info doesn't get displayed, posts, images and so on. Yet I can still see comments in the gallery (I don't think this is to blame btw)

    With this I checked the database and checked the user permissions ID table and this persons permissions were off the scale. If mine were 110 theirs was 765! it was weird, even when moving them to the lowest tiered usergroup - everything stayed the same.

    This explains to me why over the last few months, they've had issues with some posts, some people have been unable to comment on images, or like their images and so many more issues.
    The only option I can see forward, will be to start again with a new account, but as you know - when you've been on the site for so long and with many posts etc a lot won't be happy about this.
    But the whole thing is so strange, it's almost as if this account is a rogue account that is untouchable. It had a username change some time ago, but that's about it. The db id's are also fine.

    From where I am standing it most definitely seems like some sort of corruption.
    So is it possible and is there a remedy for it?
    Many thanks
     
  2. Glockie

    Glockie Well-Known Member

    Also I forgot to add, is there a way of mass moving posts from one author to another?
    I have Andy's change author but on several hundreds of posts, this will be a nightmare. So is there a way to mass move posts into another author's name?
    Thank you.
     
  3. Amaury

    Amaury Well-Known Member

    The only way is via an add-on like Andy's.
     
    Glockie likes this.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    The permission combination ID depends on many factors.

    It's possible there is permission corruption but unlikely (unless an add-on is involved).

    Disable all add-ons.
    Ensure they have no custom permissions either globally or per node.
    Toggle a permission or user group of the member to update everything.

    You can clean up unused permission combinations by running the Clean Up Permissions task in the Tools menu.
     
    Glockie likes this.
  5. Glockie

    Glockie Well-Known Member

    Okay thanks, reason I asked is because if this account IS corrupt and I make a new one for them, I will have to somehow move their content. :whistle: :X3:
     
  6. Glockie

    Glockie Well-Known Member

    Okay thank you Brogan,
    Will try these and see if that helps.
    I tried duplicating the issue with over 40 members yesterday to no avail, it is only on this account which is why I think there may be some corruption there.
    Thanks and will try these steps... :)
     
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Even if it is corrupt, it should be recoverable, so there should be no need to create a new account.
     
    Glockie likes this.
  8. Glockie

    Glockie Well-Known Member

    Okay so for arguments sake it is, doing the above steps may help? Or is there any other way I can try recovery?
    Am on it as we speak, so thanks again mate, appreciated a lot. (y)
     
  9. Glockie

    Glockie Well-Known Member

    This worked!
    I disabled everything, reset their entire permissions, including nodes, ran the cache cleaning tools and Clean Up Permissions task.
    All worked perfectly.. Thank you very much @Brogan :)
     
    Brogan likes this.

Share This Page