XF 1.3 PHP upgrade error message

I u/ld the v2.0.3 files in the 'upload' folder after d/l the forum files to a back up and got this error message: PHP 5.4.0 or newer is required. 5.3.3 does not meet this requirement. Please ask your host to upgrade PHP
I've contacted the host to see if they can do it and in the meantime I deleted the u/ld files and replaced them with the original (1.3.5) but still get the error so am a bit stuck now. Can anyone give me a quick way to get back up and running please? Maybe delete a certain file?


Chris D

XenForo developer
Staff member
Please, please, please just get your host to upgrade your PHP. That's such an archaic response they had to this problem. "Let's delete everything and go back to the start so we don't have to upgrade". Most hosts are offering one click switching to PHP 7.x.

Anyway, you'd likely need to re-upload your XF 1.3.5 files. Download them from the customer area and re-upload them.

Jake B.

Well-known member
I'd guess you don't need to upload all of them, just the .php files in the root directory index.php, admin.php, proxy.php, etc
as said I've asked the host and am awaiting a response so in the mean time re-uploaded my original 1.3.5 files whilst I wait for the php u/g. I just need the old 1.3.5 to work whilst they u/g you see. I know its way out of date and have been trying to do this for well since 1.3.5 lol and the sites pretty quiet now and so is work so I'm trying to get it all secured and upgraded before the busy period in summer...

Chris D

XenForo developer
Staff member
I actually misread your post and thought it was your host who had deleted the new files. My bad. Either way, if you're still getting that message, then the 2.0 files are still on the server. You're going to need to try and re-upload the 1.3.5 files again and obviously make sure your FTP client is told to overwrite the existing files.

If you're still having difficulty after that, you may need to use a different FTP client.

What might be worth trying first, is restarting your web server service, as that would often clear slightly overzealous over caching if you have any sort of opcache running.
ah, thought you sounded a tad harsh which isn't like you lol thanks I do think its either a cache or file overwrite thing but I did delete the v2 files then re-uploaded the v1 files so cache n rebbot it is thanks mate. I know its a temp fix and will get to v2 eventually but just found out my tiaga chat isnt v2 compatible either which is used a lot so I may hang fire. Get the PHP upraded and anything else prior to going for it. At least I know my PHP is out of date now being positive :)

Chris D

XenForo developer
Staff member
When you start thinking about it again, you may want to consider a few approaches so you can test things before going live:
  • Use the requirements test script to test you meet the minimum requirements
  • Copy your live installation and do test upgrades on that first
  • Look at which add-ons you need and whether they have XF2 versions or not. Sometimes (such as Chat) there may be alternatives from toher developers.
Good luck :) Even if you don't go to XF2 just yet, do at least consider going up to a newer PHP version. My only concern is that you're running quite an old version of XF as it is. We'd usually recommend PHP 7.2 but you'd pretty much need to be running the latest XF 1.5.18 for that to work properly.
yeah the old version of xenfor is my major concern and always has been. I've run forums for about 15 years, seen all the spambots and harvesters so know I'm running the gauntlet but I did back it all up recently db as well as all files so know I can get it back up... I just assumed all the add ons would be updated along the line but have seen thats not the case and there is another chat available thankfully. I'll be doing a lot more research now I've tinkered at long last... Oh and I just opened filezilla to find the last upload directory was the v2 upload folder.... I'm now deleting the forum files and located the v135 folder :giggle: what a f***ing tit!
cheers Chris
I've upgraded my PHP to 5.4 and 5.6 and re-uploaded the v2 files but still get the php error? am I missing something? I hope this is in the right place? please move it accordingly if not thanks...
it won't work but maybe its a firefox thing? My VPS does give me the option to u/g plesk from v12 to v17 but its a trial and will probably have to pay monthly for it in future but it will give me php v7.2...

$phpVersion = phpversion();
if (version_compare($phpVersion, '5.4.0', '<'))
    die("PHP 5.4.0 or newer is required. $phpVersion does not meet this requirement. Please ask your host to upgrade PHP.");

$dir = __DIR__;
require($dir . '/src/XF.php');

my forum admin file has this in it:

Chris D

XenForo developer
Staff member
What exactly is the error you’re getting and when?

If it’s a warning about 5.6 then you can ignore that and proceed. If it’s a plain white screen with an error about needing PHP 5.4 then your server hasn’t been upgraded as you expect and you’re still running a version below PHP 5.4.