1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug PHP Timeout and PHP Info Wrong

Discussion in 'Resolved Bug Reports' started by Snog, Nov 20, 2014.

  1. Snog

    Snog Well-Known Member

    This has had me baffled for a while now. I've quadruple checked the PHP configuration files, reboot the server just to be safe and until now couldn't figure out what was happening. And I'm still not completely sure why it is.

    On a certain site, some XF operations, such as setting registered user group permissions time out with this error: Fatal Error: Maximum execution time of 120 seconds exceeded

    That isn't usually a huge problem, so I increased the time out to 180 seconds. But the error still happens.

    So, I go to admin->tools->phpinfo and here's what it shows for the local value...
    error.jpg

    Now, under normal circumstances I've believe that and hunt further. BUT an echo ini_get('max_execution_time'); shows 180 seconds as set for the site.

    AND, running the native phpinfo() also shows 180 seconds.
    error2.jpg

    So something in XF is changing that value and I'm unable to change it to a higher value.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Out of interest, what does it show if you set it in config.php?
     
  3. Mike

    Mike XenForo Developer Staff Member

    Note that XF specifically sets a 120 time limit in some places.
     
  4. Snog

    Snog Well-Known Member

    Now that is the one place I never checked.

    Someone put a 120 time limit in config.php. :cautious:
     
  5. Snog

    Snog Well-Known Member

    I've manually changed it to 180 in the two places I know XF does that.
     
  6. DaveM

    DaveM Well-Known Member

    That person must have been having a blond moment :LOL:
     

Share This Page