1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Permissions Issue

Discussion in 'Troubleshooting and Problems' started by Okuma Steve, Feb 23, 2016.

  1. Okuma Steve

    Okuma Steve Member

    I'm having trouble with permission settings on my own account. I'm the 1st account and a super admin.

    My account doesn't recognize changes to my permissions through the moderator menu in the admin cp. For any change to work I have to uncheck everything, save it, and then check the things I want and save it. If I want to change anything after that I have to clear it and do it again.

    As an example I have my analyze permissions where it shows that I have permission to use the spam cleaner, and then on the right I do not have the option to use it.

    Any ideas? It seems to only affect my account, others react normally to changes, at least the ones I've tested.

    Capture.PNG
     
  2. melbo

    melbo Well-Known Member

    Are you entering your password at the top of the admin or mod permissions screen?
    upload_2016-2-22_20-4-1.png
     
  3. Okuma Steve

    Okuma Steve Member

    You don't have to when editing moderators
     
  4. melbo

    melbo Well-Known Member

    You mentioned that you are a super admin, which needs the password entered to make changes.
     
  5. Okuma Steve

    Okuma Steve Member

    Not for me:

    Capture.PNG
     
  6. Martok

    Martok Well-Known Member

    That's only correct when editing administrators, not when editing moderators.

    The spam cleaner is only available on members who meet the Spam Cleaner User Criteria set in the ACP. Check your settings for those and adjust if necessary.
     
  7. Okuma Steve

    Okuma Steve Member

    Yes I'm aware, that was the newest member of the forum and spam settings should be there.
     
  8. Martok

    Martok Well-Known Member

    So if it's working for other moderators and not for you, what's different? Any differences in set-up etc?

    Also are you using any caching? Have you tried disabling all add-ons and then making permission changes?
     

Share This Page