1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Design Issue Permanently deleting a thread via inline mod results in a "thread not found error"

Discussion in 'Resolved Bug Reports' started by Brogan, Feb 5, 2011.

  1. Brogan

    Brogan XenForo Moderator Staff Member

    Open a thread and click on the checkbox on the first post.
    Permanently delete it and the browser refreshes back to the thread URL and an error message is displayed.

    This only happens when deleting within the thread, not from the forum view.

    error.PNG
     
    Alien and Vincent like this.
  2. Brett Peters

    Brett Peters Well-Known Member

    I just gave that a try but I was redirected to forum view after a complete delete within the thread
    Is their possibly another variable ?
     
  3. Brogan

    Brogan XenForo Moderator Staff Member

    I tried it with a thread with a single post and multiple posts, on my test installation and live site.

    I received the same result each time.
     
  4. Brett Peters

    Brett Peters Well-Known Member

  5. Brogan

    Brogan XenForo Moderator Staff Member

  6. Brett Peters

    Brett Peters Well-Known Member

    Exactly what I did but without the error

    Screen shot 2011-02-06 at 1.15.16 AM.png Screen shot 2011-02-06 at 1.15.30 AM.png Screen shot 2011-02-06 at 1.15.43 AM.png

    I am happy to supply you with log in details to my site if you wish to confirm?
     
  7. ragtek

    ragtek Guest

    I can confirm this Brogan.
     
  8. lightbox

    lightbox Active Member

    So if I understand you right, you're NOT deleting a thread from within the thread, but you delete one or more post(s) with the result of the whole thread being deleted. This might be the difference and this is where the error occurs!
    When you use the thread tools to delete the thread from within the thread, everything is ok.

    Can confirm this behavior.
     
  9. Brett Peters

    Brett Peters Well-Known Member

    Ah Ok I was using the "Delete" option but if you use the checkbox to select delete then their is an error.
     
  10. ragtek

    ragtek Guest

    The problem is the dynamic redirect in XenForo_ControllerPublic_InlineMod_Abstract

    PHP:
            return $this->responseRedirect(
                
    XenForo_ControllerResponse_Redirect::SUCCESS,
                
    $this->getDynamicRedirect()
            );
     

Share This Page