1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 People can't signup on forums!

Discussion in 'Troubleshooting and Problems' started by mrchasez, Jan 6, 2014.

  1. mrchasez

    mrchasez Active Member


    Randomly today people can no longer sign up. This has never happened before, nor have I
    changed anything on my forums the last week. I just started getting reports people can't sign
    up. I tested myself. When i clicked sign up button, the top bar thing came down, i entered a
    new username and pushed "No, create a new account now".

    Then it brought me to this page:

    The page is blank with this image:

    If i reload, the page goes to the forums on the same page but says this:
    "This action is available via POST only. Please press the back button and try again."


    Here is my forums link:

    Anyone have a solution? I have no idea what caused this. I am using version 1.1.5

    Thank you
  2. MattW

    MattW Well-Known Member

    Works OK for me:

  3. mrchasez

    mrchasez Active Member

    I have gotten numerous reports today, and I have tested on multiple browsers, and cleared my cache and i canont get to that page. It's always blank. What's strange is that
    When I used a proxy server to try it, it worked. I could only get to that page via the proxy though.

    I have no idea what's causing this.
  4. MattW

    MattW Well-Known Member

    Is this your own server? It could be a mod_security issue where your IP address has been blocked for hitting the login/login page too many times?
  5. mrchasez

    mrchasez Active Member

    First time i have been to that page in over a week or two. I only tried it because others were reporting the issue. It's on a server in the same datacenter as my server, but not my own per say. Is there anyway i can test your theory?
  6. MattW

    MattW Well-Known Member

    You'd need access to the server logs. You'd also need to be able to check if mod_security is installed on the server (could very well be if it's a shared hosting server).

    If it's working for you when you proxy to the site, and not when you don't, then it's going to be blocking your IP somewhere. Can you reboot your router to get a new IP address?
  7. mrchasez

    mrchasez Active Member

    I can't believe it would go haywire and start blocking people who have been on for the first time ever, and me as well after using the site with no issues for two years. Ill find out about mod_security.

    Edit: I have been told they don't believe its being used.
    Last edited: Jan 6, 2014
  8. MattW

    MattW Well-Known Member

    Not sure what else to suggest then unfortunately :(
  9. Brogan

    Brogan XenForo Moderator Staff Member

    I too am unable to reproduce it, despite clicking on the login many times.
    Errors of this nature are usually indicative of server and/or routing issues.
  10. mrchasez

    mrchasez Active Member

    I have asked a few members of the community and they are also experiencing this issue. Hmmm.

Share This Page