1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PBS Video Media BB Code does not support HTML5

Discussion in 'Troubleshooting and Problems' started by Andy.N, Apr 27, 2012.

  1. Andy.N

    Andy.N Well-Known Member

    Jake Bunce posted the bbcode for PBS video here http://xenforo.com/community/threads/add-more-video-sites-bb-code-media.7608/page-9#post-276650

    It works properly but I just realize that when I go to a post with this bbcode on the iPad, it will show an empty space. My guess is that iPad safari does not support Flash. However, using the iPad to go to the PBS site, the video shows correctly there.

    Here is the post on XF, and here is the pbs page http://www.pbs.org/wgbh/pages/frontline/money-power-wall-street/

    The two embedded video are

    I realize other media bbcode may run into this problem if they use flash iframe. Are there any fix this so they work on iOS?
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I can't find any alternative embed code on their site that I can use to make a different BB code.
  3. Andy.N

    Andy.N Well-Known Member

    so you mean the code to embed and the one that you play on their site are different, Jake?
    That means they switch to html5 for iOS.
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I don't have an iPad to test this, but presumably they detect the client and change the presentation appropriately. XenForo's media site system doesn't have client detection, but we could try using different embed code that is compatible with the iOS... if PBS provided that code which it appears they don't, or at least I can't find it.
  5. Andy.N

    Andy.N Well-Known Member

    You can trick your browser to use iPad user agent using this

    I use this string
    C:\Users\Andy\AppData\Local\Google\Chrome\Application\chrome.exe -user-agent="Mozilla/5.0 (iPad; CPU OS 5_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9B176 Safari/7534.48.3"

    When I go to that PBS video site, it definitely looks different (no option to embed video, etc). The browser however plays the video on my forum post but Safari/Dolphin does not.

    So it's still a mystery.

Share This Page