XF 1.5 Paypal not working

I got Paypal setup in Sandbox mode to test this. Getting an unknown upgrade connection error in the log.

Error: Connection to PayPal failed
Unknown Account

Only log entries that involve a successful payment will be attached to a user and user upgrade.

Unknown Upgrade
5 minutes ago
Transaction ID:

txn_type web_accept
payment_date 09:37:40 Jul 10, 2017 PDT
last_name buyer
residence_country US
pending_reason unilateral
item_name Account Upgrade: FTP Redirect (Skillz)
payment_gross 2.00
mc_currency USD
payment_type instant
protection_eligibility Ineligible
verify_sign AuaofqQd2e-2NuLkob0HpzqE3dYDAs1UcZxy08ounXLw6Nm4UmHDBA.-
payer_status verified
test_ipn 1
payer_email [email removed by me]
txn_id 31A2701977412594H
quantity 1
receiver_email [email removed by me]
first_name test
payment_status Pending
mc_gross 2.00
custom 1,1,token,1,1499707034,e5e483c036074c5f89cfbae68dbb8169c57fb108
charset windows-1252
notify_version 3.8
ipn_track_id 9190c4a4bfd7d
If I run openssl s_client -connect skillzservers.com:443 -tls1_2 on my server then it returns results saying TLS 1.2

Protocol : TLSv1.2
Cipher : ECDHE-RSA-AES256-GCM-SHA384

This means TSL 1.2 is working on the site, correct?
I am at a loss here. Been fooling around with this for a couple days.

When I buy the upgrade everything seems to work correctly. I am redirected to login on the paypal web site, submit the payment and then I am redirected back to my site where I get this message:

Thank you for purchasing this upgrade.

When the payment has been approved, your account will be upgraded."

I then login to the ACP and check and no upgrade occurred. I get the same error I posted above.

Connecting to my site it's running the latest libraries for SSL/TLS.
I can login to the server directly and connect to tlstest.paypa.com.

Still it isn't working.

Paul McM

We have been using the upgrade system successfully since June 3, 2017.

However, as of 8.11.17 the upgrades are not activating. Paypal is getting the money, but the user status is not changing (i.e. they are NOT getting their account upgraded).

Is anyone else having this problem?

I note that Paypal recently added new features to the "Activity" screen. This now shows functions "Print Shipping Label", "Add Tracking", "Mark as Shipped" etc.

This was working fine through mid-day 8.10.17, then something changed.

I wonder if other Xenforo users with upgrades enabled are having problems and if the XF code needs updating.


Paul McM

Thank you so much for your reply. I followed the link you sent. This revealed five (5) Paypal IPN history messages showing IPN status "disabled"

The first error message, dated 8/11/2017 17:04 PDT, appears to correspond to the first upgrade payment that did NOT generate the upgrade.

Seeing this, I went into PayPal settings:

Gear logo > Profile and Settings > My Selling Tools > Instant Payment Notifications > Update

Guess what, the IPN "Message Delivery" was showing "Disabled". I used Edit Settings to set this as "Enabled".

NOTE: We had NOT disabled messages. This appears to have happened as the result of some software change by PayPal

HAPPY ENDING -- TEST Account Upgraded Successfully

TEST WORKED: I just created a new test account membership. I created (and verified) this account, then bought a $20 Level 1 upgrade. The upgrade posted in seconds! I also see the new test account is a member of the desired upgrade group.

Separately, I did look at the XF user upgrade transaction log... there were a whole bunch of entries, but no errors corresponding to the upgrade failures that started 8.11.2017. No entries at all in last 48 hours.