XF 2.2 Password reset emails not working with Microsoft hosted emails

ktiveee

New member
Hi there,

I have tried the guide provided for email troubleshooting and still no luck.

Basically, when I have a new user register they receive their initial verification email no problem.

When I go to test sending an outbound email they also receive it without any issues.

However, if that same user requests to reset their password they do not receive their email - no errors on XF end, no errors within hosts end and mail server either.

The email simple does not come through at all and it is for some reason affecting only Microsoft hosted emails such as hotmail/outlook/live.

All of the other email providers are receiving emails no problem and they are pretty instant too. Tested on yahoo/gmail/mail.ru/icloud - everything is working fine and as it should. It is for some reason only Microsoft hosted ones.

Any ideas?
 

jeb35

Well-known member
Have them check their spam box. Something in the email could be setting off the spam trigger or that particular email isn't setup correctly?
 

Brogan

XenForo moderator
Staff member
MS are well known for blacklisting server IPs.

You will likely need to request your server IP address be removed from the list.
 

ktiveee

New member
Have them check their spam box. Something in the email could be setting off the spam trigger or that particular email isn't setup correctly?

The email is setup correctly as they receive test emails and the initial verification email without any issues

MS are well known for blacklisting server IPs.

You will likely need to request your server IP address be removed from the list.

IP is not blacklisted as the issue is only with specifically reset password function and all other emails come through without any issues and the initial and test emails both do not end up in spam folder so that wouldn't be an issue either
 

ktiveee

New member
If its only affecting MS domains then you need to contact them.

Thank you for the suggestion! Any ideas why its specifically doing that only to reset password ones? I feel like maybe there's something with XF that I need to address as the other two emails are coming through fine.
 

ENF

Well-known member
Thank you for the suggestion! Any ideas why its specifically doing that only to reset password ones? I feel like maybe there's something with XF that I need to address as the other two emails are coming through fine.
No. I can attest to the MS issue. It's their issue, not yours (or XF) I've stuck warnings up for people using MS accounts due to the constant issues of mail delivery on their mail platforms. They are the only mass email provider that we really face issues with and this has gone on for years.

If you are having repeated occurrences on any other non-MS email service, then I would look at your mail configs (SPF, DMARC, etc.).
 
Top