1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Parent_List in xf_style (Can I just change style_id ?)

Discussion in 'XenForo Questions and Support' started by LPH, Apr 18, 2014.

  1. LPH

    LPH Well-Known Member

    I have a local XF install in which the StyleID default is 1. Everything appears to work. A live production site had the default style ID at 29. I went into the database and changed the style ID from 29 to 1. Things appear to work but I noticed that the parent list for the local install is "312c30" and the live production was "1,0"

    What is the difference between these designations? Do I need to do anything with cache?

    Note: I have an external widget which works on a local dev environment as well as a test environment online, but not the live production site. The style IDs were the only difference (that I could tell). I'm trying to figure out why the widget fails. No error messages are logged.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    The parent list is to do with the heirarchy of the style.

    The values are, in order: this style, parent, grandparent, root.

    I changed the style ID once and as long as you update the style_id and parent_id it's fine.
     
  3. LPH

    LPH Well-Known Member

    Thank you for the explanation. I'm still concerned that the external widget fails to load on the live production site but works on the local dev and another site. The only difference was the style ID. Well, there has to be another difference ... guess I'll keep looking to figure out what is different.
     
  4. LPH

    LPH Well-Known Member

    I found the problem. It was a conflict with another add-on. I removed that add-on and my external widget works :)
     

Share This Page