1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pages broken after upgrade

Discussion in 'Installation, Upgrade, and Import Support' started by RAH, Jan 28, 2011.

  1. RAH

    RAH New Member


    For some reason after upgrading to RC1 the pages under our nodes section have stopped working. They all give 404 errors, even newly created ones.

    How do we go about resolving this?

    Thanks for your help.
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Pages work fine on my RC1 test forum.

    Maybe it's a problem with a custom style or addon.

    1) Try to reproduce the problem on a default style. Create a new style with no parent:

    Admin CP -> Appearance -> Styles -> Create New Style

    Then select that style on your forum. If the problem goes away when using the new style then you know it's a problem with your custom style.

    2) Try disabling your addons:

    Admin CP -> Home -> List Add-ons -> Disable (in the Control menu for each addon)
  3. RAH

    RAH New Member

    Disabling addons doesn't resolve the issue.

    I'm using the default style however have added additional links to the header for these pages, perhaps this is where the problem is.
    Here's an example page link structure:

    Was the structure changed with RC1?
  4. a legacy reborn

    a legacy reborn Well-Known Member

    Check to make sure your .htaccess is there with the correct contents and then make sure that in Options in AdminCP that you have all the SEO Options Set
  5. RAH

    RAH New Member

    I had 'Use Full Friendly URLs' enabled and the .htaccess file supplied with RC1 in place. In this instance the pages worked fine however the login system was completely broken, so I had to disable this option and delete the .htaccess file.

    The login system was redirecting to the following which didn't exist:
  6. Decent60

    Decent60 Well-Known Member

    you might want to try the .htaccess file like this:

    <IfModule mod_rewrite.c>
    RewriteEngine On


    RewriteCond %{REQUEST_FILENAME} -[OR]
    RewriteCond %{REQUEST_FILENAME} -d
    ^.*$ - [NC,L]
    RewriteRule ^(data|js|styles|install) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
  7. RAH

    RAH New Member

    Thanks. What do I do with this if XenForo is installed in the root of my site and not a sub-directory?
  8. Decent60

    Decent60 Well-Known Member

    It would still be like
    Or it might simply be /public_html/
    I am not 100% sure on that, try one and if it doesn't work, then it's the other lol
  9. RAH

    RAH New Member

    Unfortunately this didn't resolve the issue.

    The login URL is still being incorrectly formed - site.com/login/login
  10. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That is a valid URL if you are using friendly URLs. What happens when you try to login? Is there an error? What is the error?

    If you are using friendly URLs then make sure you use the htaccess file provided with xenForo. Or you can also disable friendly URLs (which is a good troubleshooting step if nothing else):

    Admin CP -> Home -> Options -> Search Engine Optimisation (SEO) -> Use Full Friendly URLs
  11. RAH

    RAH New Member

    When attempting to login it redirects to site.com/login/login which gives a 404 error.

    Yes, I tried both the .htaccess file provided with RC1 and the one posted above.
  12. Brogan

    Brogan XenForo Moderator Staff Member

    There's obviously something we're missing here.

    I would upload the entire upgrade package once again to the server, to ensure all the files are correct.
    Then check for outdated templates and revert them or even create a new default style.
    Test the login functionality and pages then.

    If it's still not working then ideally we would need a link to the site URL and a test login/admin access to try and figure out what the problem is.

Share This Page