[OzzModz] Post Comments

[OzzModz] Post Comments 2.0.1 Patch Level2

No permission to download

deslocotoco

Well-known member
there are two options... you can set the number of nests and you can set how many nests are visible at page load. to load deeper nests, user can click on a link to expand. There is no limit to how many comments can be made. I have it disabled at the moment coz merging posts feature didn't work. I can turn it on if you want to check it out right now and post a bunch of comments in test section.

Thanks for the reply.

In the old thread by ThemeHouse, there a bunch of errors reporting and bugs.

Do you think this is a very stable release by Ozzy or is better to wait a little more?

BTW, if anyone comment, the user will be alerted about having a reply like in normal quotes?

And, suppose the post is number 3 in the page, if users comment in the post, it will be bumped to a new location or will stay in the same place?
I ask this because i have threads with more than 25k pages, and my users are concerned about their posts getting lost if they use this new system.

Of course i think they will learn when to use properly this new comment system, without loosing the traditional quotes. This add-on approach in a more modern way of the old and traditional Forums, just see Reddit for example.
 

Mr Lucky

Well-known member
BTW, if anyone comment, the user will be alerted about having a reply like in normal quotes?
My test show that this is not the case.

Also (in this could be a biggie) comments do not show up under New posts. However they do show under latest activity.
 
Last edited:

TheGroove

Active member
I think both alerts and showing up in new posts are key for this so I'll be watching to see if those items are addressed before testing. It's a great idea for an addon and addresses a real need, particular for those who like to go off topic. Well done.
 

questlot

Active member
The addon works well. But just a little issue. When a comment is made the time stamp from forumview doesn't get updated that there is a recent reply. No alert to indicate there is a new post added.
 

Ozzy47

Well-known member
I think that is to be expected, as it’s a comment not a post. But I’ll look into it when I get some free time.
 

teletubbi

Well-known member
Got 2 error messages.

  • InvalidArgumentException: Accessed unknown getter 'thpostcomments_root_reply_count' on XF:Thread[46840]
  • src/XF/Mvc/Entity/Entity.php:203

  • Generiert von: Asiadragon
  • 1 Dezember 2021 um 06:08


Stack-Trace​


#0 src/XF/Mvc/Entity/Entity.php(115): XF\Mvc\Entity\Entity->get('thpostcomments_...')
#1 internal_data/code_cache/templates/l2/s44/public/thread_list_macros.php(404): XF\Mvc\Entity\Entity->offsetGet('thpostcomments_...')
#2 src/XF/Template/Templater.php(962): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, Object(XF\Template\ExtensionSet))
#3 src/XF/Template/Templater.php(898): XF\Template\Templater->renderExtensionInternal('main_cell', Array, Array, Object(XF\Template\ExtensionSet))
#4 internal_data/code_cache/templates/l2/s44/public/thread_list_macros.php(553): XF\Template\Templater->renderExtension('main_cell', Array, Object(XF\Template\ExtensionSet))
#5 src/XF/Template/Templater.php(799): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, Object(XF\Template\ExtensionSet))
#6 internal_data/code_cache/templates/l2/s44/public/widget_new_posts.php(26): XF\Template\Templater->callMacro('thread_list_mac...', 'item', Array, Array)
#7 src/XF/Template/Templater.php(1626): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, NULL)
#8 src/XF/Widget/WidgetRenderer.php(62): XF\Template\Templater->renderTemplate('widget_new_post...', Array)
#9 src/XF/Widget/WidgetRenderer.php(67): XF\Widget\WidgetRenderer->render()
#10 src/XF/Template/Templater.php(1901): XF\Widget\WidgetRenderer->__toString()
#11 internal_data/code_cache/templates/l2/s44/public/forum_overview_wrapper.php(11): XF\Template\Templater->widgetPosition('forum_overview_...', Array)
#12 src/XF/Template/Templater.php(1626): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, NULL)
#13 src/XF/Template/Templater.php(1023): XF\Template\Templater->renderTemplate('forum_overview_...', Array, false)
#14 src/XF/Template/Templater.php(1641): XF\Template\Templater->applyWrappedTemplate('










...')
#15 src/XF/Template/Template.php(24): XF\Template\Templater->renderTemplate('forum_list', Array)
#16 src/XF/Mvc/Renderer/Html.php(48): XF\Template\Template->render()
#17 src/XF/Mvc/Dispatcher.php(458): XF\Mvc\Renderer\Html->renderView('XF:Forum\\Listin...', 'public:forum_li...', Array)
#18 src/XF/Mvc/Dispatcher.php(440): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#19 src/XF/Mvc/Dispatcher.php(400): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#20 src/XF/Mvc/Dispatcher.php(58): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#21 src/XF/App.php(2300): XF\Mvc\Dispatcher->run()
#22 src/XF.php(488): XF\App->run()
#23 index.php(20): XF::runApp('XF\\Pub\\App')
#24 {main}


Status der Anfrage​


array(4) {
["url"] => string(8) "/forums/"
["referrer"] => bool(false)
["_GET"] => array(0) {
}
["_POST"] => array(0) {
}
}

and

  • ErrorException: Template error: [E_USER_WARNING] Accessed unknown getter 'thpostcomments_root_reply_count' on XF:Thread[46840]
  • src/XF/Mvc/Entity/Entity.php:199

  • Generiert von: Asiadragon
  • 1 Dezember 2021 um 06:08


Stack-Trace​


#0 [internal function]: XF\Template\Templater->handleTemplateError(512, '[E_USER_WARNING...', '/var/www/html/p...', 199, Array)
#1 src/XF/Mvc/Entity/Entity.php(199): trigger_error('Accessed unknow...', 512)
#2 src/XF/Mvc/Entity/Entity.php(115): XF\Mvc\Entity\Entity->get('thpostcomments_...')
#3 internal_data/code_cache/templates/l2/s44/public/thread_list_macros.php(404): XF\Mvc\Entity\Entity->offsetGet('thpostcomments_...')
#4 src/XF/Template/Templater.php(962): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, Object(XF\Template\ExtensionSet))
#5 src/XF/Template/Templater.php(898): XF\Template\Templater->renderExtensionInternal('main_cell', Array, Array, Object(XF\Template\ExtensionSet))
#6 internal_data/code_cache/templates/l2/s44/public/thread_list_macros.php(553): XF\Template\Templater->renderExtension('main_cell', Array, Object(XF\Template\ExtensionSet))
#7 src/XF/Template/Templater.php(799): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, Object(XF\Template\ExtensionSet))
#8 internal_data/code_cache/templates/l2/s44/public/widget_new_posts.php(26): XF\Template\Templater->callMacro('thread_list_mac...', 'item', Array, Array)
#9 src/XF/Template/Templater.php(1626): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, NULL)
#10 src/XF/Widget/WidgetRenderer.php(62): XF\Template\Templater->renderTemplate('widget_new_post...', Array)
#11 src/XF/Widget/WidgetRenderer.php(67): XF\Widget\WidgetRenderer->render()
#12 src/XF/Template/Templater.php(1901): XF\Widget\WidgetRenderer->__toString()
#13 internal_data/code_cache/templates/l2/s44/public/forum_overview_wrapper.php(11): XF\Template\Templater->widgetPosition('forum_overview_...', Array)
#14 src/XF/Template/Templater.php(1626): XF\Template\Templater->{closure}(Object(SV\StandardLib\XF\Template\Templater), Array, NULL)
#15 src/XF/Template/Templater.php(1023): XF\Template\Templater->renderTemplate('forum_overview_...', Array, false)
#16 src/XF/Template/Templater.php(1641): XF\Template\Templater->applyWrappedTemplate('










...')
#17 src/XF/Template/Template.php(24): XF\Template\Templater->renderTemplate('forum_list', Array)
#18 src/XF/Mvc/Renderer/Html.php(48): XF\Template\Template->render()
#19 src/XF/Mvc/Dispatcher.php(458): XF\Mvc\Renderer\Html->renderView('XF:Forum\\Listin...', 'public:forum_li...', Array)
#20 src/XF/Mvc/Dispatcher.php(440): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#21 src/XF/Mvc/Dispatcher.php(400): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#22 src/XF/Mvc/Dispatcher.php(58): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#23 src/XF/App.php(2300): XF\Mvc\Dispatcher->run()
#24 src/XF.php(488): XF\App->run()
#25 index.php(20): XF::runApp('XF\\Pub\\App')
#26 {main}


Status der Anfrage​


array(4) {
["url"] => string(8) "/forums/"
["referrer"] => bool(false)
["_GET"] => array(0) {
}
["_POST"] => array(0) {
}
}
 

WRIST.xxx

Member
It's an excellent addition to a site, I can vouch for that. We had 17,000+ comments before ThemeHouse went boobs-up with it, then Ozzy rescued it (and me, because members were getting out the pitchforks and putting on their running shoes).

I too would love it if notifications worked with the comments like they do with posts. So many use comments and so many "comments" are going unnoticed. I'm hoping when you look, @Ozzy47, that in the code there is a checkbox that says "Programmer, you can turn on notifications for comments by clicking this box". LOL. Wouldn't life be grand if it were that easy. Thanks for a great add-on!
 
I was using [UW] Forum Comments System but I had to disable it due to a message handling problem: when a user has the ability to post a comment, this is seen as a post so many old threads would be replayed with a simple comment. Is it possible to have a block for comments on posts older than x days?
 

zoldos

Well-known member
@Ozzy47 Two issues: 1. When I download the add-on, it says "ThemeHouse". I thought it was made by you? 2. It doesn't work. lol I checked permissions, add-on settings, etc., and it just won't work. Replies won't nest, and when I set it to replace the reply and quote buttons, that doesn't work either. I'm using ThemeHouse UIX theme.

Thanks for any assistance, would like to try the mod!
 

Ozzy47

Well-known member
It was made by ThemeHouse, I’m just maintaining it.
Most likely it’s an issue with your custom theme. Try on a unmoddified default style.
 
Top