XF 2.1 Outgoing Emails Failing

Hi,

I have had SMTP setup for a while now with Namecheap PrivateEmail and all of a sudden some emails are failing to send and this is the error I’m getting:
Code:
ErrorException: Email to user@example.com failed: [E_WARNING] fgets(): SSL: An existing connection was forcibly closed by the remote host. src\vendor\swiftmailer\swiftmailer\lib\classes\Swift\Transport\StreamBuffer.php:171
Generated by: LordWaycrest Mar 2, 2021 at 1:06 AM
Stack trace
#0 [internal function]: XF::handlePhpError()
#1 src\vendor\swiftmailer\swiftmailer\lib\classes\Swift\Transport\StreamBuffer.php(171): fgets()
#2 src\vendor\swiftmailer\swiftmailer\lib\classes\Swift\Transport\AbstractSmtpTransport.php(397): Swift_Transport_StreamBuffer->readLine()
#3 src\vendor\swiftmailer\swiftmailer\lib\classes\Swift\Transport\AbstractSmtpTransport.php(289): Swift_Transport_AbstractSmtpTransport->_getFullResponse()
#4 src\vendor\swiftmailer\swiftmailer\lib\classes\Swift\Transport\AbstractSmtpTransport.php(117): Swift_Transport_AbstractSmtpTransport->_readGreeting()
#5 src\XF\Mail\Mailer.php(274): Swift_Transport_AbstractSmtpTransport->start()
#6 src\XF\Mail\Mail.php(395): XF\Mail\Mailer->send()
#7 src\XF\Admin\Controller\Tools.php(278): XF\Mail\Mail->send()
#8 src\XF\Mvc\Dispatcher.php(350): XF\Admin\Controller\Tools->actionTestEmail()
#9 src\XF\Mvc\Dispatcher.php(257): XF\Mvc\Dispatcher->dispatchClass()
#10 src\XF\Mvc\Dispatcher.php(113): XF\Mvc\Dispatcher->dispatchFromMatch()
#11 src\XF\Mvc\Dispatcher.php(55): XF\Mvc\Dispatcher->dispatchLoop()
#12 src\XF\App.php(2184): XF\Mvc\Dispatcher->run()
#13 src\XF.php(391): XF\App->run()
#14 admin.php(13): XF::runApp()
#15 {main}
Request state
array(4) {
  ["url"] => string(27) "/admin.php?tools/test-email"
  ["referrer"] => string(52) "https://www.klodghirz.com/admin.php?tools/test-email"
  ["_GET"] => array(1) {
    ["tools/test-email"] => string(0) ""
  }
  ["_POST"] => array(2) {
    ["email"] => string(23) "user@example.com"
    ["_xfToken"] => string(8) "********"
  }
}

I can’t seem to figure out what he issue is so I’d like some help please, many thanks.
 
It looks like Namecheap is closing the email connection. Try without an SSL and see if it's the same issue. Make sure the SMTP port/host is correct.
Hi,

I fixed it thank you. For some reason Namecheap was prompting me to change the password on the inbox, wouldn't of known as I don't login to the noreplies.

Many thanks,
Lewis
 
Top