1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Out of memory errors help

Discussion in 'Troubleshooting and Problems' started by dknife, Mar 23, 2016.

  1. dknife

    dknife Active Member

    The last month or so I've been getting out of memory errors on occasion, they aren't consistent and I'm not sure how to track them down. I've tried to research the issue but seemingly most causes previously have been bad hosting configs. I'm on a shared hosting server with 1Gb memory and 256Mb allocated in php.ini but I've never seen my memory usage go much higher than 100Mb. Also the memory allocation in the errors indicates it's way below the limit.

    The errors don't seem to be consistent as far as activity performed on the forum. Sometimes it's a thread view, login, member profile. This morning I got 6 of them all generated at the same time.

    ErrorException: Fatal Error: Out of memory (allocated 10223616) (tried to allocate 786432 bytes) -library/XenForo/Template/Abstract.php(265) : eval()'d code:2137
    Generated By: Unknown Account, Today at 6:21 AM
    Stack Trace
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    Request State
    array(3) {
    ["url"] => string(54) "https://yaktribe.org/community/members/zalinsky.14373/"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(0) {
    }
    }

    ErrorException: Fatal Error: Out of memory (allocated 9175040) (tried to allocate 734175 bytes) -library/Zend/Db/Statement/Mysqli.php:294
    Generated By: spafe, Today at 6:21 AM
    Stack Trace
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    Request State
    array(3) {
    ["url"] => string(39) "https://yaktribe.org/community/members/"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(0) {
    }
    }

    ErrorException: Fatal Error: Out of memory (allocated 9961472) (tried to allocate 786432 bytes) -library/XenForo/Template/Abstract.php(265) : eval()'d code:2137
    Generated By: spafe, Today at 6:21 AM
    Stack Trace
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    Request State
    array(3) {
    ["url"] => string(39) "https://yaktribe.org/community/members/"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(0) {
    }
    }

    ErrorException: Fatal Error: Out of memory (allocated 9175040) (tried to allocate 734175 bytes) -library/Zend/Db/Statement/Mysqli.php:294
    Generated By: spafe, Today at 6:21 AM
    Stack Trace
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    Request State
    array(3) {
    ["url"] => string(39) "https://yaktribe.org/community/members/"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(0) {
    }
    }

    ErrorException: Fatal Error: Out of memory (allocated 8388608) (tried to allocate 734155 bytes) -library/Zend/Db/Statement/Mysqli.php:276
    Generated By: Unknown Account, Today at 6:21 AM
    Stack Trace
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    Request State
    array(3) {
    ["url"] => string(80) "https://yaktribe.org/community/threads/close-combat-gang-model-suggestions.4164/"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(0) {
    }
    }
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Out of memory errors generally indicate that memory_limit isn't being hit, but something else is limiting the amount of memory PHP can use.

    Are you on a shared server?
    Do you have any other software running on the same server/domain?

    Any cron tasks or batch files running at that time?
     
  3. dknife

    dknife Active Member

    Yes it's a shared server. I personally don't have any other sites running on my account. I have a cron job for a db backup once daily but the oom errors seem to be outside of that timeframe and that's a very quick cron job (50mb database).

    Another example even outside of the forum

    ErrorException: Fatal Error: Out of memory (allocated 262144) (tried to allocate 50750160 bytes) -Unknown:0
    Generated By: Unknown Account, Yesterday at 6:56 PM
    Stack Trace
    #0 [internal function]: XenForo_Application::handleFatalError()
    #1 {main}
    Request State
    array(3) {
    ["url"] => string(21) "https://yaktribe.org/"
    ["_GET"] => array(0) {
    }
    ["_POST"] => array(0) {
    }
    }

    Guess I should go to my host for this issue.
     
  4. dknife

    dknife Active Member

    My host increased my PHP memory_limit to 512mb and also switched my PHP from 5.5 to 5.6. Errors seem to have gone.
     

Share This Page