• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Optimizing for XenForo and Some Editor Lag

TeflonDon

Well-known member
#1
Just switched to XF from VB. So far things seem to be quicker than they were on VB but not as fast as some other XF forums I've visited. My server was configured to best suit vBulletin so I expect I'll have to make some changes.

Also, I've noticed some lag when typing in the editor. It seems to only happen when you're replying to a thread with a lot of replies (I have it set to display 30 messages/page). When replying to a thread say with only 1 or 2 message there doesn't seem to be any lag, and same thing when sending a PC.


I'll be happy to provide any info about my server configuration, just let me know what you need.

Thanks!
 

TeflonDon

Well-known member
#3
Your database should be using Innodb as default engine.
For caching, if you're on a single server APC is a win :)
Btw, 30 messages per thread is a bit huge.
I do know that we're now using Innodb. I'll have to check about APC.

A good amount of my members set their messages per page to 50 when using vBulletin. Seeing how XF doesn't allow an option for that, I had to compromise and set it at 30. I also never noticed any performance issues when using 50 posts per page on vb 3.8
 

TeflonDon

Well-known member
#4
Enabled APC but I'm still having some lag in the editor.

$config['cache']['frontend'] = 'Core';
$config['cache']['frontendOptions'] = array(
'caching' => true,
'automatic_serialization' => true,
'lifetime' => 10800
);
$config['cache']['backend'] = 'Apc';


apc
APC Supportenabled
Version 3.1.13
APC Debugging Disabled
MMAP Support Enabled
MMAP File Mask no value
Locking type pthread read/write Locks
Serialization Support php
Revision $Revision: 327136 $
Build Date Jul 22 2013 15:50:30