1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

OpenLiteSpeed PHP Compile Error

Discussion in 'Server Configuration and Hosting' started by TDUBS, Sep 10, 2014.

  1. TDUBS

    TDUBS Active Member

    Hello,

    Upon compiling PHP in OpenLiteSpeed on my CentOS 6.5 server, I ran across the below error:

    Code:
    **MAIN_STATUS** retrieved from /usr/local/lsws/phpbuild/buildphp_1410353982.9.progress
    Start building PHP 5.5.15 with LSAPI
    Configuring PHP build (2-3 minutes)
    Compiling PHP (5-10 minutes)
    Installing PHP
    copy compiled php binary to litespeed directory
    Start building APC Extension
    Changing to build directory /usr/local/lsws/phpbuild/php-5.5.15/APC-3.1.9
    Running PHPize for APC extension
    Configuring APC extension build
    Compiling APC extension
    **ERROR** Could not compile APC extension
    and

    Code:
    /usr/local/lsws/phpbuild/php-5.5.15/APC-3.1.9/apc_zend.c: In function 'apc_get_zval_ptr':
    /usr/local/lsws/phpbuild/php-5.5.15/APC-3.1.9/apc_zend.c:62: error: 'zend_execute_data' has no member named 'Ts'
    /usr/local/lsws/phpbuild/php-5.5.15/APC-3.1.9/apc_zend.c:64: error: 'zend_execute_data' has no member named 'Ts'
    /usr/local/lsws/phpbuild/php-5.5.15/APC-3.1.9/apc_zend.c:67: error: 'zend_execute_data' has no member named 'CVs'
    /usr/local/lsws/phpbuild/php-5.5.15/APC-3.1.9/apc_zend.c: In function 'apc_op_ZEND_INCLUDE_OR_EVAL':
    /usr/local/lsws/phpbuild/php-5.5.15/APC-3.1.9/apc_zend.c:170: error: 'zend_execute_data' has no member named 'Ts'
    /usr/local/lsws/phpbuild/php-5.5.15/APC-3.1.9/apc_zend.c:170: error: 'zend_execute_data' has no member named 'Ts'
    /usr/local/lsws/phpbuild/php-5.5.15/APC-3.1.9/apc_zend.c:170: error: 'zend_execute_data' has no member named 'Ts'
    /usr/local/lsws/phpbuild/php-5.5.15/APC-3.1.9/apc_zend.c:171: error: 'zend_execute_data' has no member named 'Ts'
    make: *** [apc_zend.lo] Error 1
    **ERROR** Could not compile APC extension
    I am setting this up for my forum. If you require any more information, please let me know.

    Thanks!
     
  2. RoldanLT

    RoldanLT Well-Known Member

  3. Tracy Perry

    Tracy Perry Well-Known Member

    It may be because APC is not compatible with PHP 5.5.x series?
     
    lsmichael and TDUBS like this.
  4. TDUBS

    TDUBS Active Member

    I checked Slavik's tutorial and he used 5.4.x I believe. Would it hurt if I used that version?
     
  5. RoldanLT

    RoldanLT Well-Known Member

    Definitely :D
    APC is only developed last PHP 5.3 era.
     
    lsmichael and TDUBS like this.
  6. TDUBS

    TDUBS Active Member

    It worked with 5.4.x :) Thanks @Tracy Perry and @RoldanLT
     
    Tracy Perry likes this.
  7. eva2000

    eva2000 Well-Known Member

    FYI, APC 3.1.9 is too old for PHP 5.5, you need to use APC 3.1.15-dev with PHP 5.5 (that's why Centmin Mod for PHP 5.5/5.6 work with APC Cache)
     
  8. TDUBS

    TDUBS Active Member

    Appreciate that. I was using the default check boxes in LiteSpeed's PHP Compiler. They had PHP 5.5 and APC checked by default, so I went with it.. ran across this error and went ahead and used PHP 5.4 instead.
     
  9. lsmichael

    lsmichael Member

    Hmmm... That doesn't sound like a good way to have the defaults set up... What version are you using? It doesn't show up this way on the version I have set up, but I'm using 1.3.something.

    Michael
     
  10. TDUBS

    TDUBS Active Member

    By default, when you clicked "Compile PHP," there was a list of PHP versions from oldest to newest, and 5.5.x being the newest. I first selected 5.5.x, hit next, checked the boxes next to PHP Mail Header Patch, APC V3.1.9, and memcache V2.2.7 (all options by default - see pic below). Apparently APC V3.1.9 is too old for 5.5.x so I went back and chose the next lowest version of PHP (5.4.x) which worked perfect.

    [​IMG]
     
  11. lsmichael

    lsmichael Member

    No, no, no. Sorry. I wasn't clear. I understand the issue, but I don't see it in my version of OpenLiteSpeed. You are probably using a different version than I am. What version of OpenLiteSpeed are you using?

    m
     
  12. TDUBS

    TDUBS Active Member

    Litespeed Web Server Open 1.3.4
     
  13. lsmichael

    lsmichael Member

    Oh. Wait. Apparently, I didn't understand the issue. I thought you said APC was checked by default.

    Ah. You just mean we shouldn't allow it as a checkbox when PHP 5.5 is chosen. Point taken. I don't know, though, whether we'll be able to build that in any time soon. (We should also probably not allow people to check more than one opcode cache.) Thanks for the feedback!

    Michael
     
  14. TDUBS

    TDUBS Active Member

    No problem. APC wasn't checked by default, but I noticed when you do check APC with the latest PHP version (5.5.x), it will not work. Only works with 5.4.x and lower.
     

Share This Page