XF 2.0 Oops we ran into some problems.

vanucci

Active member
Hi guys, i know this isnt a bug with the software and its an issue server side.

I'm getting this issue on a fresh install



Now When i check console I get these errors



Very unsure of what this may be ?

I have CentOS7 WHM PHP 7.1
 

fpandjic

Member
How did you solve the issue?

I'm getting similar issue:

Failed to load resource: the server responded with a status of 403 (Forbidden)

core-compiled.js:42 PHP: <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>403 Forbidden</title>
</head><body>
<h1>Forbidden</h1>
<p>You don't have permission to access /mxcro/forum/admin.php
on this server.</p>
</body></html>
 
Last edited:

vanucci

Active member
Ok, my .htaccess file didnt have mod rewrite on it. Solved the issue.

added a .htaccess file to the root directory. Mine was pretty much empty.

this is my htaccess contents

Code:
#    Mod_security can interfere with uploading of content such as attachments. If you
#    cannot attach files, remove the "#" from the lines below.
#<IfModule mod_security.c>
#    SecFilterEngine Off
#    SecFilterScanPOST Off
#</IfModule>
 
ErrorDocument 401 default
ErrorDocument 403 default
ErrorDocument 404 default
ErrorDocument 500 default
 
<IfModule mod_rewrite.c>
    RewriteEngine On
 
    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo
 
    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
 
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
from this post https://xenforo.com/community/threads/the-default-htaccess-file.47906/

@fpandjic @John71
 

fpandjic

Member
I have also solved the problem, but it was slightly different in my case. It was provider-related. Rewriterule was enabled by default, but the problem was next:

"It looks like Comodo WAF was a little bit too aggressive and has blocked some XSS requests. We have added it to whitelist"
 

carntheroos4eva

Well-known member
I have also solved the problem, but it was slightly different in my case. It was provider-related. Rewriterule was enabled by default, but the problem was next:

"It looks like Comodo WAF was a little bit too aggressive and has blocked some XSS requests. We have added it to whitelist"
Check with your host that they haven't put it on their whitelist
 

fionix

Active member
had a similar problem and it was clouflare and the WAF which made troubles. When you disable WAF you will have to wait a few minutes before it is disabled and then try again.
 
Top