• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Old domain (vBulletin) keeps trying to send mail?

rainmotorsports

Well-known member
#3
Do you want vBulletin to still exist? Left over files when requested by ANYTHING is going to generate a database error when it cant connect to the database. It's doing what it was designed to do. It's designed to email you when the database server can't be connected to. Fix it or delete it.
 

dutchbb

Well-known member
#5
Do you want vBulletin to still exist? Left over files when requested by ANYTHING is going to generate a database error when it cant connect to the database. It's doing what it was designed to do. It's designed to email you when the database server can't be connected to. Fix it or delete it.
Correct ;) host just mailed and confirmed this. So it is indeed a left over file i have to find.

I took over the forum when it was on xenforo 1.5, no experience with vBulletin. Only the domain has to stay for redirects and if i am reading the posts from previous admin correct on this forum also some files.
 
Last edited:

dutchbb

Well-known member
#7

Tracy Perry

Well-known member
#8
I asked our host about that, but he said it was a script trying to connect with the database. I think it are redirects connecting with this:

http://forum.dutchbodybuilding.com/external.php?type=RSS2&forumids=9

So the redirect is requesting this and that tries to connect to the (non-excisting) database and gives an error. But i could be wrong :p
A simple redirect would not connect to the DB... so there has to be a PHP file in existence somewhere on the server that the redirect hits that attempts the connection. If on a server you have SSH access to, simply do a (if logged in with root priv already no need for sudo)
sudo updatedb
sudo locate external.php
and that should give you the location of any file called external.php
 

dutchbb

Well-known member
#9
Was checking the redirects in place (from vbseo) and are a little more complex then the information i can find here.

1. no import_log, only from mediagallery. Import forum has been done external service.
2. redirect rules placed in the old domain htacces file.

In the log files from that old domain i can see that there are comming requests in for links (attachments, threads and posts).

The external.php file was in public_html

Part of the log

Code:
ip- - [16/Jul/2017:14:00:06 +0200] "GET /external.php?type=RSS2&forumids=8 HTTP/1.0" 503 2984 "-" "CaRP/4.0Evolution"
ip - - [16/Jul/2017:14:00:06 +0200] "GET /external.php?type=RSS2&forumids=9 HTTP/1.0" 503 2984 "-" "CaRP/4.0Evolution"
ip - - [16/Jul/2017:14:00:15 +0200] "GET /f10/index323.html HTTP/1.1" 404 215 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
ip - - [16/Jul/2017:14:00:22 +0200] "GET /f141/index324.html HTTP/1.1" 404 216 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
ip - - [16/Jul/2017:14:00:24 +0200] "GET /f22/zma-zink-monomethionine-aspartaat-32645/ HTTP/1.1" 301 250 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0"
ip - - [16/Jul/2017:14:00:24 +0200] "GET /f9/voedingswaarden-voorbeeldschemas-24805/ HTTP/1.1" 301 250 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36 Google Favicon"
ip - - [16/Jul/2017:14:00:26 +0200] "GET /f64/mosquitos-log-173814/ HTTP/1.1" 301 251 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36 Google Favicon"
ip - - [16/Jul/2017:14:00:27 +0200] "GET /f64/diary-a-washed-up-meathead-252797/ HTTP/1.1" 301 251 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36 Google Favicon"
ip - - [16/Jul/2017:14:00:27 +0200] "GET /f81/snoobs-logboek-368435/ HTTP/1.1" 301 251 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36 Google Favicon"
ip - - [16/Jul/2017:14:00:27 +0200] "GET /f32/wie-gaan-meer-uitdaging-om-doelen-scherper-stellen-187145/ HTTP/1.1" 301 251 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36 Google Favicon"
ip - - [16/Jul/2017:14:01:01 +0200] "GET /f66/index27.html HTTP/1.1" 404 214 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
ip - - [16/Jul/2017:14:01:09 +0200] "GET /f253/recomposition-log-288774/ HTTP/1.1" 301 251 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36 Google Favicon"
ip - - [16/Jul/2017:14:01:13 +0200] "GET /f172/index38.html HTTP/1.1" 404 215 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
ip - - [16/Jul/2017:14:01:25 +0200] "GET /f22/index42.html HTTP/1.1" 404 214 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
ip - - [16/Jul/2017:14:01:37 +0200] "GET /f134/ HTTP/1.1" 301 246 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
ip - - [16/Jul/2017:14:01:49 +0200] "GET /f10/1ste-kuur-opheldering-gevraagd-278830/index2.html HTTP/1.1" 404 251 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
ip - - [16/Jul/2017:14:02:01 +0200] "GET /f9/ontbijt-beetje-klaar-grote-shake-graag-weer-vaste-voeding-366811 HTTP/1.1" 404 265 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
ip- - [16/Jul/2017:14:02:10 +0200] "GET /f9/olijfolie-301089 HTTP/1.1" 404 217 "-" "Mozilla/5.0 (compatible; DotBot/1.1; http://www.opensiteexplorer.org/dotbot, help@moz.com)"
ip - - [16/Jul/2017:14:02:13 +0200] "GET /f8/optimale-pomp-behalen-112803/ HTTP/1.1" 301 251 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36 Google Favicon"
ip - - [16/Jul/2017:14:02:13 +0200] "GET /f8/waarom-goed-om-pomp-spieren-krijgen-55945/ HTTP/1.1" 301 250 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36 Google Favicon"
ip - - [16/Jul/2017:14:02:13 +0200] "GET /f8/pomp-7695/ HTTP/1.1" 301 249 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36 Google Favicon"
ip - - [16/Jul/2017:14:02:13 +0200] "GET /f8/kun-stellen-groter-pomp-des-beter-resultaat-19277/ HTTP/1.1" 301 250 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36 Google Favicon"
ip - - [16/Jul/2017:14:02:14 +0200] "GET /f201/pec-zwolle-topic-348099 HTTP/1.1" 404 226 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
ip - - [16/Jul/2017:14:02:17 +0200] "GET /f32/voorronde-sterkste-man-belgie-2012-a-294030/ HTTP/1.1" 301 251 "-" "Mozilla/5.0 (compatible; DotBot/1.1; http://www.opensiteexplorer.org/dotbot, help@moz.com)"
ip - - [16/Jul/2017:14:02:23 +0200] "GET /f62/grote-superdudes-2009-topic-195842/ HTTP/1.1" 301 251 "-" "Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"
ip - - [16/Jul/2017:14:02:25 +0200] "GET /f201/wk-kwalificatie-belgie-brazilie-here-come-333546/index6.html HTTP/1.1" 404 263 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
ip - - [16/Jul/2017:14:02:37 +0200] "GET /f9/index1363.html HTTP/1.1" 404 215 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
ip - - [16/Jul/2017:14:02:41 +0200] "GET /f106/ HTTP/1.1" 301 246 "-" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1)"
ip - - [16/Jul/2017:14:02:49 +0200] "GET /f224/index41.html HTTP/1.1" 404 215 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
ip- - [16/Jul/2017:14:02:55 +0200] "GET /f75/spierpijn-95172/ HTTP/1.1" 301 250 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36 Google Favicon"
ip - - [16/Jul/2017:14:03:01 +0200] "GET /f183/index101.html HTTP/1.1" 404 216 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
ip- - [16/Jul/2017:14:03:04 +0200] "GET /f32/squat-rx-150029/ HTTP/1.1" 301 251 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.75 Safari/537.36 Google Favicon"
ip - - [16/Jul/2017:14:03:13 +0200] "GET /f172/index72.html HTTP/1.1" 404 215 "-" "Mozilla/5.0 (compatible; bingbot/2.0; +http://www.bing.com/bingbot.htm)"
(server ip) - - [16/Jul/2017:14:03:16 +0200] "GET /attachment.php?attachmentid=13236&stc=1&d=1268619578 HTTP/1.0" 503 3006 "-" "XenForo/1.5 (https://forum.bodybuilding.nl)"
 

Attachments

Last edited:

dutchbb

Well-known member
#10
.htacces file old domain

Code:
RewriteOptions inherit

RewriteEngine on
RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
RewriteCond %{REQUEST_URI} !^/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
RewriteRule ^f[0-9]+/[^/]+-([0-9]+)/$ http://forum.bodybuilding.nl/topics/$1/ [R=301,L]
RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
RewriteCond %{REQUEST_URI} !^/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
RewriteRule ^f([0-9]+)/$ http://forum.bodybuilding.nl/fora/$1/ [R=301,L]
RewriteCond %{HTTP_HOST} ^.*$
RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
RewriteCond %{REQUEST_URI} !^/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
RewriteRule ^/?$ "https\:\/\/forum\.bodybuilding\.nl\/" [R=301,L]
 

dutchbb

Well-known member
#11
I checked in the mail queue log and the errors are not only from external.php

example showthread.php (many more in the log like
search.php and so on..)

Date:
Sun, 16 Jul 2017 21:56:59 +0200
From:
DBmaster@example.com
To:
DBmaster@example.com
Subject:
vBulletin Database Error!
Message-Id:
<E1dWpf1-0000oB-7b>
Received:
from dutchbodybuilding.com with local (Exim 4.89)
(envelope-from <dutchbodybuilding.com>)
id 1dWpf1-0000oB-7b
for dbmaster@example.com; Sun, 16 Jul 2017 21:56:59 +0200
Sender:
<dutchbodybuilding.com>
X-PHP-Originating-Script:
1010:class_core.php
X-PHP-Script:
forum.dutchbodybuilding.com/showthread.php
Database error in vBulletin :

Cannot use database forum

MySQL Error : Access denied for user 'forum'@'localhost' to database 'forum'
Error Number : 1044
Request Date : Sunday, July 16th 2017 @ 07:56:59 PM
Error Date : Sunday, July 16th 2017 @ 07:56:59 PM
Script : http://forum.dutchbodybuilding.com/showthread.php?p=6573803
Referrer :
IP Address :
Username :
Classname : vB_Database_MySQLi
MySQL Version :
 
Last edited:

Tracy Perry

Well-known member
#12
Is this an actual vB install that you are asking about or a XenForo one. If XenForo those files should not be present for vB at all.
From the errors you are showing, those files are still physically present. Did you delete the vB DB that they are calling?
As for the log, that's to be expected, especially if the script was changed from one to another lately and no rewrites put into place.
 
Last edited:

dutchbb

Well-known member
#13
A Xenforo one.

The files and logs posted here are from the old domain dutchbodybuilding.com

On that old domain vBulletin was installed. When previous admin transfered to Xenforo he also changed domain to bodybuilding.nl

The Database of vBulletin has been deleted. Only files are left over with rewrites in the htacces file.
 

Tracy Perry

Well-known member
#14
Well, on the mail log one it appears to be using a file called class_core.php and the showthread.php. It really looks like somewhere you still have files in play for vBulletin script itself. Otherwise you would not be getting error reports on not being able to connect to the DB. How did you/he "delete" the old vBulletin install?
I'm not familiar with vBulletin but I imagine those were core files.
 

dutchbb

Well-known member
#15
I have no idea how he deleted the vBulletin install and also can't ask him because he past away.

But as far as i can see on cpanel and phpmyadmin there is nothing left over but files.

Showthread.php is an importart file that is also used in the redirect scripts.
https://xenforo.com/community/resources/redirection-scripts-for-vbulletin-3-x.264/

Different php files like that are being requested and gives an error because trying to connect to non-excisting database.
 

Tracy Perry

Well-known member
#16
I have no idea how he deleted the vBulletin install and also can't ask him because he past away.

But as far as i can see on cpanel and phpmyadmin there is nothing left over but files.

Showthread.php is an importart file that is also used in the redirect scripts.
https://xenforo.com/community/resources/redirection-scripts-for-vbulletin-3-x.264/

Different php files like that are being requested and gives an error because trying to connect to non-excisting database.
Then it may be something you have to deal with if other sites have direct links (which is most likely) to the files being called. How long ago was the move? It may be something that ends up having to be ignored, but I find it unusual that if those files are required by the redirect scripts that are used by XenForo then it should be handling it.
I'd suggest submitting a ticket since this actually looks like it may be something related to the official redirect package.
 

dutchbb

Well-known member
#17
Also old internal links could do this. The move was in September 2015.

The redirect scripts from xenforo (link) are not used. Only thing i can find is the rewrites in the htacces file old domain and also new domain.

So the old links on the forum and other sites are doing a request to the old domain php files. I also think they are not nescesarry, will take a backup and remove them to test and try to find out how the redirects are set up.
 

dutchbb

Well-known member
#18
I submited a ticket to be sure and is fixed now ;)

In your old /includes/config.php file you had a setting to email on database problems.

I disabled the email option.

The old vBulletin files do not need to be kept, only the .htaccess as far as I can see. I can not tell you however if you may have old files, images etc referenced.