1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Odd Font Issue on FireFox...

Discussion in 'Off Topic' started by Jaxel, May 13, 2011.

  1. Jaxel

    Jaxel Well-Known Member

    Untitled-1.png

    The top is Chrome, the bottom is FireFox. This is a brand new computer, and a completely unmodified version of FireFox. I installed it, and this is how it looked. ALL fonts in FireFox look like this, even the menu system. How do I fix this?
     
  2. Shelley

    Shelley Well-Known Member

    In the support area.
     
    Vodkaholic likes this.
  3. Lawrence

    Lawrence Well-Known Member

    Jaxel, this is happening to all web pages or just XenForo?

    The only setting I can find in FF is Options -> Content -> Fonts -> Advanced, and ensure the check box for allowing web sites to pick the fonts is selected.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    It's not just fonts looking at the Twitter and FB icons.
     
  5. Wuebit

    Wuebit Well-Known Member

    You seem to have 3 body fonts




    Code:
    body {
        font-family: Helvetica,Arial,sans-serif;
    }
    
    body {
        color: #141414;
        font-family: 'Trebuchet MS',Helvetica,Arial,sans-serif;
        line-height: 1.27;
        word-wrap: break-word;
    }
    
    body {
        font: 13px/1.231 arial,helvetica,clean,sans-serif;
    }
    Might have something to do with it.
     
  6. Luke F

    Luke F Well-Known Member

    DirectWrite font rendering does horrible things like that - disable it and use ClearType.

    One thing you could try if you want to fix the issue is setting a solid background on the element that directly contains the text.
     
  7. Forsaken

    Forsaken Well-Known Member

    Fonts are rendered differently in different browsers.

    You also might want to check to see if ClearType is enabled.
     
  8. Jaxel

    Jaxel Well-Known Member

    ClearType is enabled... these seems to be some massive anti-aliasing going on in FireFox to the point that its unreadable.

    It happens on ALL websites... it even happens in the FireFox options screen. I am using ClearType.
     
  9. SilverCircle

    SilverCircle Well-Known Member

    1) Open a new tab
    2) Type about:support

    Scroll down and check what the graphics section says. If it says Direct2D / DirectWrite enabled, you probably have issues with your video driver or its settings. This *can* be hard to solve on some systems. Sometimes, you can fix it by adjusting your settings for antialiasing and anisotropic filtering on your video drivers.

    Also, make sure you have Windows 7 SP1 installed as it fixes a lot of Direct2D rendering problems - most of these fixes also come with IE9.

    The easiest *workaround* (not really a fix) is to disable DirectWrite/Direct2d. On options->advanced select the General tab and disable the setting for hardware acceleration if you cannot fix it by adjusting driver settings. However, this will disable all hardware accelerated features thus you'll lose the performance benefits of the retained layers in Firefox 4.

    Other method:

    in about:config

    1) set gfx.direct2d.disabled to true
    2) check that gfx.direct2d.force-enabled is set to false

    To preserve Direct3d accelerated layers (and thus most of the performance benefits), make sure that:

    1) layers.acceleration.disabled is false
    2) layers.prefer-d3d9 is true
    3) layers.use-d3d10 is false

    This will revert to old, GDI based rendering while keeping the important layer acceleration enabled. GDI based font rendering will respect clear type preferences while DirectWrite font rendering ignores it.

    Note that changing any of these settings requires a restart of Firefox.

    It's a mess that happens on some systems and is not always easy to fix. Some of the problems are being worked on and some have already been fixed in the current nightly builds of Aurora.
     
  10. Jaxel

    Jaxel Well-Known Member

    I turned off "Morphological Filtering" in the Catalyst Control Center... now its working fine.

    And people wonder why I don't like Firefox. If I was a "normal" person, an issue like this renders the browser completely unusable.
     
  11. Forsaken

    Forsaken Well-Known Member

    You could still read, so it isn't unusable. Unpleasant, but still usable.
     
  12. Jaxel

    Jaxel Well-Known Member

    When the entire screen is full of fonts like that... it hurts your eyes. So it is unusable.
     

Share This Page