1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Odd APC behaviour

Discussion in 'Off Topic' started by Laric, Apr 27, 2011.

  1. Laric

    Laric Active Member

    I was trying to upgrade my APC to 3.1.7 yesterday.

    Code:
    sudo pecl uninstall apc-3.1.6
    sudo pecl install apc-3.1.7
    sudo /etc/init.d/apache2 restart
    
    When I do this then xenforo stops working totally. I checked with the apc.php that it seems work just fine.

    Code:
    sudo pecl uninstall apc-3.1.7
    sudo pecl install apc-3.1.6
    sudo /etc/init.d/apache2 restart
    
    Makes it work instantly again.

    I should also make note that the only apc reference in my php.ini is extension=apc.so

    in the config.php I have the following.
    PHP:
    $config['cache']['frontend'] = 'Core';
    $config['cache']['frontendOptions'] = array(
                                            
    'caching'                      => true,
                                            
    'automatic_serialization'      => true,
                                            
    'lifetime'                      => 10800,
                                            
    'cache_id_prefix' => 'foro'
    );
    $config['cache']['backend'] = 'Apc';
     
  2. Laric

    Laric Active Member

    This is not quite off topic (as it has been moved to by some mod).. I can't get XF to work with APC 3.1.7.

    Hopefully someone does read in this forum aswell :)
     
  3. Brogan

    Brogan XenForo Moderator Staff Member

    This is more server configuration and optimisation, rather than a XenForo support related issue.

    I take the point that they are inter-related but the general support forum is really for XenForo only.

    There is a plan to implement some more specific forums, such as server configuration, etc. so I will see if we can get that pushed out.
     
  4. CyclingTribe

    CyclingTribe Well-Known Member

    Check php.ini for [ extension_dir = "/path/on/your/server" ] and confirm that your apc.so file exists in this location.

    Are any errors reported in your Apache log file?

    What version of PHP are you using?

    Does PECL do a make install and create a new apc.so file?

    Cheers,
    Shaun :D
     
  5. Laric

    Laric Active Member

    geeks.. my apc.php shows that the apc is working. I t shows the correct version and all. Just can't get xf to load with it.
     
  6. Laric

    Laric Active Member

    Starting to think it is because ubuntu builds php5 with suhosin.

    To me it seems that suhosin is soo much more pain than it is worth.
     
  7. Laric

    Laric Active Member

    Ok found a workaround the problem.
    Installed APC 3.1.8 today and had the same problem.

    As ubuntu uses the suhosin patch there is no real way to disable it.
    So I installed php5-suhosin that installs the extension suhosin that sort of overrides the patch.
    The good news is you can disable the extesion through a "suhosin.simulation = On" in your php.ini

    Then the newer apc and xf works nicely together again.

    Really odd but I am happy as it works :)
     
    GeeksChat likes this.

Share This Page