Occasionally white-pages on my forum

Abraham54

Well-known member
Occasionally white-pages occur on my forum, this happened frequenter after switching to PHP 8.1.

Back in PHP 8.0.14 seemed to halve solved the problem.
But nu 2 times in the last three days the white pages occurred again.
This time there was error reporting on the white page:

Code:
XF\Db\AbstractStatement->getException() in src/XF/Db/Mysqli/Statement.php at line 198
XF\Db\Mysqli\Statement->getException() in src/XF/Db/Mysqli/Statement.php at line 79
XF\Db\Mysqli\Statement->execute() in src/XF/Db/AbstractAdapter.php at line 96
XF\Db\AbstractAdapter->query() in src/XF/Session/DbStorage.php at line 57
XF\Session\DbStorage->writeSession() in src/XF/Session/Session.php at line 221
XF\Session\Session->save() in src/XF/Pub/App.php at line 462
XF\Pub\App->complete() in src/XF/App.php at line 2354
XF\App->run() in src/XF.php at line 517
XF::runApp() in index.php at line 20


No errors were recorded in Admin or on the server.
I have no clue why this happens.
 

Abraham54

Well-known member
@fly, I think now it was related to PHP 8.1.
There were other problems, like Firefox, that seemed slow on my forum.
Yesterday I switched back to PHP 7.4 and from that moment on, my forum became much faster.
 
  • Like
Reactions: fly

Abraham54

Well-known member
Today, one of my mods encountered a white page:
An unexpected database error occurred. Please try again later

Is this correct: xf_database add-on: XenForo 2.2.8 Patch 1
 

Abraham54

Well-known member
For the first time the server error logged this:
Code:
[Sun Apr 03 19:06:53.861566 2022] [lsapi:error] [pid 22295:tid 140490259101440] [client [host134.19.185.116:40618]www.piepcomp.nl]
Connect to backend failed with CONNECTION_RESET on sending request(GET / HTTP/1.1); uri(/):
ReceiveAckHdr: backend reset connection: errno 104 (possibly memlimit for LVE ID 1204 too small),
check http://docs.cloudlinux.com/mod_lsapi_troubleshooting.html, referer: https://www.piepcomp.nl/
 

Abraham54

Well-known member
My forum is on share hosting and I now suspect that other websites nibble in the resources of my forum.

Vimexx, my current host, has made an adjustment, the total memory range has gone from 6GB to 12GB.

Screenshot 2022-04-04 at 17-14-20 web0083.zxcs.nl - DirectAdmin v1.63.5.png

Now I have to wait, if new timeouts happen.

By the way, in May my forum will be moved to another host with Python available.
 
Last edited:
Top