1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Occasional Issue: Internal Server Error when replying to a post

Discussion in 'Troubleshooting and Problems' started by iaresee, Nov 7, 2015.

  1. iaresee

    iaresee Member

    I can't reproduce this with 100% reliability so I'm hesitant to call it a bug. Only a few of us have encountered it.

    I hit it yesterday when I was trying to do a quoted reply to this post on my site: http://forum.fractalaudio.com/threa...erfect-strat-fender-tone.105915/#post-1269598

    As soon as I started the reply I got the following pop up in my browser:
    I also got the pop up trying to post the reply and my ability to reply was blocked.

    If I quoted and replied to any other post in the thread I didn't get the error. If I just straight replied to the thread I didn't get the error.

    I tried clearing the browser cache and reloading the page and it persisted. I tried using Chrome instead of Safari and the problem occurred there as well. There are no errors reported in the Server Log in the Admin CP, no errors caught by New Relic, no errors in my Apache logs. There was nothing unusual happening on the board at the time this occurred. It was its usual level of busy and no one else was complaining.

    I went away for the day, came back this morning thinking I'd try it again and this time watch the Javascript console in my browser but, of course, today it's working fine. I can reply to and quote that post just fine now.

    Any tips on how to debug this? So far it's only been reported by accounts who are administrators on the board so hopefully it's not hitting the general user base.

  2. Brogan

    Brogan XenForo Moderator Staff Member

    Is there anything in the server (not ACP) error log?

    That may hold some clues as to the cause.
  3. iaresee

    iaresee Member

    Completely empty, I'm afraid:

    Screen Shot 2015-11-07 at 10.05.52 AM.png
    I am slightly worried the New Relic stuff is catching them and dropping them. The only error to-date that New Relic has reported from the site is that DateTimeZone::__construct(): Unknown or bad timezone () error I reported earlier that's a non-error.

    If I can recreate it, I'll get Javascript Console output when it occurs.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    The server error log, not the ACP error log.
  5. iaresee

    iaresee Member

    Opps. Sorry.

    Yes. Not sure how I missed this yesterday.

    See: https://gist.github.com/ianchesal/e38b3636882875f4bdc2

    Hmm. ModSecurity being overzealous? I would assume that'd be something I could reproduce though...
  6. Brogan

    Brogan XenForo Moderator Staff Member

    Yes, it's mod_security triggering it.

    You should be able to analyse what's causing it and whitelist the rule(s).
    iaresee likes this.
  7. iaresee

    iaresee Member

    Thanks. Do you know where in the code that query is being triggered? It happens when I start a reply, so I'm thinking it's an auto-save thing, maybe?
  8. Brogan

    Brogan XenForo Moderator Staff Member

    I see a couple of issues:

    Generic SQL injection protection
    Execution error - PCRE limits exceeded

Share This Page