1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Not showing any IP

Discussion in 'Troubleshooting and Problems' started by DennisSkov, Sep 30, 2014.

  1. DennisSkov

    DennisSkov Active Member

    Hi,

    Since today (or late yesterday), IP's are no longer being logged on my forum. I've made no changes to anything, and I noticed this when a new user had no IP assigned.

    upload_2014-9-30_17-30-8.png

    What could be causing this?
     
  2. Tracy Perry

    Tracy Perry Well-Known Member

    Very likely due to the fact you are using CloudFlare. You need to check your config.php to make sure it's correct for their proxy setup. With their SSL changes they are doing it may have changed.
     
  3. DennisSkov

    DennisSkov Active Member

    I didn't start using CloudFlare before today, more specifically a couple of hours ago. It was also a problem before I turned on CF.
     
  4. Tracy Perry

    Tracy Perry Well-Known Member

    Then check to make sure your hosting provider is not using a proxy on the front end of their HTTP server (something like nginx in front of Apache or Varnish in front of Apache) if you are on a shared host. If on a VPS or Dedi then there may be some other issues.
     
  5. Tracy Perry

    Tracy Perry Well-Known Member

    OK, now I see what you are referring to... you can no longer see the IP link in the post. Check your permissions and are you sure that you haven't updated a style or added any add-ons lately (or updated them).
    To make sure, disable all add-ons via config.php and try a default style to see if it shows.
     
  6. DennisSkov

    DennisSkov Active Member

    It's not a problem with permissions. I haven't touched anything since last week, and this started happening within the last 24 hours.
    See this image
    [​IMG]


    Here's the log:
    http://pastebin.com/4NiqKiSZ
     
  7. Tracy Perry

    Tracy Perry Well-Known Member

    I keep seeing ReCaptcha in there... are you using Google's recaptcha service. I know a lot of people have been having connection problems with it. If could be something as simple as a temporary error or something as complicated as the connection being blocked by your host or them now.
     
  8. DennisSkov

    DennisSkov Active Member

    I'm using the default ReCaptcha. And no, it hasn't got something to do with that. IP's aren't being logged anywhere - not for visiting members, new registrations or existing members.
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    Contact your host and check whether they have made any changes.

    Things don't just stop working for no reason.
     
  10. Tracy Perry

    Tracy Perry Well-Known Member

    OK.. back to step 1... are you on shared hosting or dedi/vps?

    If shared hosting, have you checked with them to see if they have made any recent changes.

    If dedicated hosting/VPS, has whomever managed it made any changes?
     
  11. DennisSkov

    DennisSkov Active Member

    I've already contacted them. They had a problem where hotmail, live and outlook was blocking all mails from my IP, and they fixed that.

    It's shared hosting.
     
  12. Tracy Perry

    Tracy Perry Well-Known Member

    On this aspect, you need t ask them if they are using a proxy on the front end (varnish, nginx, etc) of the HTTP server. The blocking of email has nothing to do with this - other than the fact your IP was either on a blacklist or you didn't have DKIM/SPF enabled.
     
  13. DennisSkov

    DennisSkov Active Member

    I contacted them some months ago when all visitors on the website came from the same IP as my webserver had. They are in fact using a proxy, but they have been for ages. I'm just gonna wait for an answer from them. Thanks for the help.
     
  14. Tracy Perry

    Tracy Perry Well-Known Member

    They may have changed something in the setup of the proxy and you will probably need to modify the string in the config.php that you have set currently.
     
  15. DennisSkov

    DennisSkov Active Member

    It was a problem with my host. They just answered my ticket and said that all should be fixed now - and it is. Thanks for all the help :)
     
    Tracy Perry likes this.

Share This Page