1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 non-www appears as duplicate site

Discussion in 'Troubleshooting and Problems' started by Cassandra, Jan 18, 2016.

  1. Cassandra

    Cassandra Member

    1) I have a wordpress/forum setup where the forum is a subfolder i.e www.mysite.com/forum.
    2) On my blog .htaccess file, I set up 301 redirect so whenever someone clicks mysite.com/forum they're automatically redirected to www.mysite.com/forum.
    3) However, when I check my referral traffic (in wordpress, for example) I occasionally see some clicks from mysite.com/forum (non-www). When I click that, my forum is seen as a completely duplicate site, with me not being logged in at all.
    4)I should note this happens only with the forum part of the site, not the blog part.
    5)Google Analytics whines that I have redundant host names (probably because of the above).
    6)Below is my forum .htaccess file (from the /forum subfolder). How should I fix this?

    # Mod_security can interfere with uploading of content such as attachments. If you
    # cannot attach files, remove the "#" from the lines below.
    #<IfModule mod_security.c>
    # SecFilterEngine Off
    # SecFilterScanPOST Off

    ErrorDocument 401 default
    ErrorDocument 403 default
    ErrorDocument 404 default
    ErrorDocument 405 default
    ErrorDocument 406 default
    ErrorDocument 500 default
    ErrorDocument 501 default
    ErrorDocument 503 default

    <IfModule mod_rewrite.c>
    RewriteEngine On

    # If you are having problems with the rewrite rules, remove the "#" from the
    # line that begins "RewriteBase" below. You will also have to change the path
    # of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo

    # This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
  2. Brogan

    Brogan XenForo Moderator Staff Member

  3. Cassandra

    Cassandra Member

    Thanks @Brogan , I have added the following:

    RewriteBase /forum
    RewriteCond %{HTTP_HOST} ^mysite.com$ [NC]
    RewriteRule ^(.*)$ http://www.mysite.com/$1 [R=301,L]

    however now the old non-www links instead of automatically referring to the www, they show 404 errors. What am I doing wrong?
  4. Cassandra

    Cassandra Member

    On a different thread, it seems like someone found a solution:
    RewriteBase /forum
    RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
    RewriteRule ^ http://%1%{REQUEST_URI} [NE,R=301,L]

    But I need to move from non-www to www. How to apply?
  5. Cassandra

    Cassandra Member

Share This Page