XF 2.0 nofollow links in signatures

#1
Hi there,

I've just noticed that the links in my signature in XF2 are set to "nofollow noopener". Can this be changed so they are set to follow please?

Fingers crossed....

Andy
 

Chris D

XenForo developer
Staff member
#2
Any XF user who is marked as a staff member will not have nofollow applied to any of their links, including signatures.

Marking a user as a staff member is actually separate to their moderator or administrator state so you may need to go and edit your user record in the Admin CP and check this box:

1520520672538.png

After that, the external links in your own signature will simply be noopener but that's an important security feature which is applied to all external links.
 
#3
Thanks for the advice. I've edited and it's now removed the "nofollow":)

I've also just noticed that my sig isn't visible to guests. Is there a setting somewhere that shows it to all please?

Many thanks,

Andy
 
#5
Hi there,

Is the setting 'nofollow' not harmfull for spidering the entire site. I mean when I am f.e. on this page https://xenforo.com/community/forums/xenforo-suggestions.18/ I see al lot of 'nofollow' on internal links, which means that the google spider shall not follow that link. For external links I understand the 'nofollow' attribute but for internal links I don't.
Same question for the 'nofollow' attribute on the 'what's new'section.
 
Top