XF 2.1 Node Titles Disappeared

Alfuzzy

Active member
The main node titles/headings for each group of sub-nodes have disappeared on my site. I've inspected each node in the AdminCP...and the node text is still in place. I do not believe any text colors were changed (where the text color & text background are the same color making the text appear invisible).

This issue is in a theme/style I've created. If I revert to the default XF style...the missing node titles reappear.

I not sure what happened to make them disappear in the theme I created. They were there a couple hours ago...now they're gone.

Any ideas please?

Thanks

p.s. Sample image attached. The black arrows point to the headings that are missing on my site. Only the top level headings have disappeared...the sub-forums headings/titles are still visible.
 

Attachments

  • Missing Headings.png
    Missing Headings.png
    70.9 KB · Views: 5

Alfuzzy

Active member
I generally prefer to not post links to my site for security reasons. Thanks:)

In regards to the question...I will try provide as much info as possible to help find the solution.

Here's an image of what things look like now (arrows indicate missing title info for each subject category). I have 8 categories like this on the Home Page...all 8 heading descriptions are missing for each category...and as can be seen...the sub-forum category titles are fine.

MIssing Headings 2.png

In the AdminCP >> Forums >> Nodes. If I check each individual node...the proper text/description is in place. Here's an example of one of them:


Missing Headings 3.png


Finally if I go into the AdminCP >> Appearance >> Style Properties >> Basic Colors. All text colors are either black or red or yellow. Colors that should be easily seen against a white backgrund.

Since all 8 of the category headings are the effected on the home page...seems to me this could be a setting of some sort effecting all of them equally. But I'm not an expert.

Anyone have any suggestions/ideas?

Thanks
 

Alfuzzy

Active member
Thanks very very much I3ta...that worked...now I'm getting the proper title headings in the areas that were missing earlier!:)

Missing Headings 4.png

Two follow up questions please:

1. This is a new XF install...migrated from a vB4 site...and the XF extra.less template was totally blank (before adding what you mentioned). Should the extra.less template be 100% empty in a situation like this?

2. Just so I do this 100% correct the first time. If I want to modify this very same major title area towards the theme/style I would like (change the background color & the text color)...where do I do it in the AdminCP?

Thanks very very much for the help...this issue REALLY had me stumped! Lol
 

l3ta

Well-known member
You're welcome, Alfuzzy.

1. If it is a new style, then yes. Extra.less should be empty of modifications.

2. In your ACP, go to Appearance>Styles>Style properties>Blocks>Block header.
 

Alfuzzy

Active member
You're welcome, Alfuzzy.

1. If it is a new style, then yes. Extra.less should be empty of modifications.

2. In your ACP, go to Appearance>Styles>Style properties>Blocks>Block header.
Awesome...thanks for the ACP path. I went there...and I think I found the problem. Somehow the text color for the block header got changed to white...probably the same color as the background (so the text basically appeared invisible).

block text color 1.png

I changed the color to dark red...and the titles in the block headers are now dark red.:)

block text color 2.png

block text color 3.png

I also removed the code from the extra.less template...it's now back to being 100% empty!

Thanks very very much again for the help. I couldn't have figured it out without you!!!:)
 

Alfuzzy

Active member
Hello everyone. I would like to:

  • Change the color of the Block Header (hopefully this is what it's called)....at the top of thread lists & top of each individual posting within a thread.
  • Maybe add some text to each of these if possible.
  • Color the text...if possible to color the text.

Can someone please point me where in the ACP the settings are for these? I looked in the ACP >> Styles >> Style Properties >> Blocks...but wasn't 100% sure if this was the correct area...and if it is...which exact area controls each of these items.

Images of each area I'm referring to in case it's not 100% clear:

Thread Header (top of thread list for a forum category)...color, add text, color text:

Thread List Header Color.png

Top of each individual post within an individual thread (color, and text, color text):

Post Header Color.png

Thanks much.:)
 

l3ta

Well-known member
Put this in extra.less:

Code:
.block-filterBar {background: black;}

.filterBar-menuTrigger {color: white;}

.message-attribution {background: black; color: white; padding: 5px 5px 5px 5px}
 

Alfuzzy

Active member
You're a GENIUS I3ta...worked perfectly!:)

Even the "Filters" drop down window text color on the right side of the filter bar is visible too.

What if I wanted to change the "hover color" for the icons in the message-attribution bar?

I changed the message attribution bar color to deep red. These icons are white for non-hover...and red for hover. When I hover over them...they turn red & kind of get lost in the color of the message-attribution bar.

Thread Post Header Bar.png

Thanks much!:)
 
Top