• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Node (Sponsored by) Image

wickedstangs

Well-known member
#2
Alright been playing around with this...

How can I move it over to the right?
sponser2.JPG

Code:
.nodeList .node_32 .nodeTitle:after {
content:"SPONSORED BY" url('@imagePath/path/to/image.png');
display: inline;
vertical-align: middle;
padding-right: 4px;
}
 

wickedstangs

Well-known member
#11
@FredC and @TwistedMerlin thanks for your help.. I think I got it working the way I want and responsive too:)
sponser.JPG

Extra.css
Code:
.nodeList .node_33 .nodeTitle::after {
content:"SPONSORED BY:" url('http://www.wickedstangs.com/images/Sponsors/ajeracingbannersm.jpg');
position: relative;
display: inline;
float: right;
text-align: center;
min-height: 32px;
line-height: 32px;
font-size: 14px;
}
 
Last edited:
#12
@FredC and @TwistedMerlin thanks for your help.. I think I got it working the way I want and responsive too:)
View attachment 98775

Extra.css
Code:
.nodeList .node_33 .nodeTitle::after {
content:"SPONSORED BY:" url('http://www.wickedstangs.com/images/Sponsors/ajeracingbannersm.jpg');
position: relative;
display: inline;
float: right;
text-align: center;
min-height: 32px;
line-height: 32px;
font-size: 14px;
}
Is there anyway to make the image clickable? Thanks!
 

wickedstangs

Well-known member
#15
No way of making clickable using the :after that I know of.

You'd have to edit the template: node_forum_level_2 I think?

Then do a xen:if is node conditional to show a specific image for that node. You could use this as somewhat of a guide if you wanted too: https://xenforo.com/community/threads/button-post-new-thread-at-homepage.90557/ completely different but html placement is almost the same.
Russ sent you a couple of question on your site about zipped and thanks for the above..
 

wickedstangs

Well-known member
#16
ok anyone have this issue?

This is a different issue, I have found that I hope someone can help.

When I log off zip my Sponsor image disappears.
logoff.JPG

When I log in my Sponsor image appears...
logon.JPG

This is my Extra.css Code
Code:
.nodeList .node_30 .nodeTitle::after {
content:"SPONSORED BY:" url('http://foxbodymustangs.org/images/200x71.png');
position: relative;
display: inline;
float: right;
text-align: center;
min-height: 32px;
line-height: 32px;
font-size: 14px;
}
 

Russ

Well-known member
#17
You'll probably want to disable the "NEW" indicators on the style: Style Properties -> [XB] Nodes ->

Enable New Thread Indicator, seems like it's conflicting with it. I'll check your thread over on PE shortly.