1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

node ID on body tag?

Discussion in 'Styling and Customization Questions' started by Dion Sune Jensen, Sep 8, 2012.

  1. Dion Sune Jensen

    Dion Sune Jensen Active Member

    I need to add a lot of styling individually on a lot of pages, so I was trying to figure out what to add to PAGE_CONTAINER so that it would get an #id which is the id of the node that it's displaying (should work for any type of content, be it a page, forum category etc. as their ID's should be unique)

    Anyone who can point me in the right direction?
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  3. Dion Sune Jensen

    Dion Sune Jensen Active Member

  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  5. Dion Sune Jensen

    Dion Sune Jensen Active Member

    The PAGE_CONTAINER template has been edited, but the code for the <body> tag is identical to the one from the default style:
    Code:
    <body{xen:if {$bodyClasses}, ' class="{$bodyClasses}"'}>
    The pagenode_container has not been changed and is identical with default.
     
  6. Dion Sune Jensen

    Dion Sune Jensen Active Member

  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Only if you are using a really old version. I fixed that bug a long time ago. And I have just confirmed that it's still fixed in the latest version.
     
  8. Dion Sune Jensen

    Dion Sune Jensen Active Member

    Really weird, since it's a completely new install from just a few days ago, I can pastebin the PAGE_CONTAINER and pagenode_container templates if you want, but I don't see anything in them that should prevent the classes being added (it literally adds none of the classes to the body tag)
     
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I can take a look if you give me admin access.
     
    Shelley likes this.

Share This Page