• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

As designed No way to uninstall a partial failed install of addon

Affected version
Beta 4

arms

Active member
#1
I have an addon that failed install.

I sits in "Installable add-ons" and has the Install button, but there are Templates, Class extensions etc already created which i cannot uninstall or disable unless i do it manually for each.
 

Mike

XenForo developer
Staff member
#2
If the installer failed at some point, running it again should pick up from the step that it failed on (if it's a step-based installer). However, at that point, no data will have been imported yet so I'm surprised you have the templates, etc unless it failed at a later point. If it failed later, then reattempting an install should allow it to pick up the data import and resolve the install issue.
 

arms

Active member
#3
If it failed later, then reattempting an install should allow it to pick up the data import and resolve the install issue.
It failed on the template modification import, and errors out. So ended up with errors until i disabled manually everything that had installed.
 

Mike

XenForo developer
Staff member
#4
Presumably this is the error you ran into? https://xenforo.com/community/threa...ifications-for-non-existing-templates.134952/ In which case, fixing issues like that should be the priority.

If add-on installation hasn't completed, it doesn't really make sense to allow it to be uninstalled. The installation will be in an unknown state, so it's very possible that the uninstall code will start to fail too. When you get into an undefined situation like that, the add-on developer is very likely to need to be involved to determine what actions are necessary.

In this case, because it failed after the add-on controlled code completed, you're in a better state, though there's still definitely some undefined situations so it's best to report any errors you're getting, especially during this beta process.
 

Jake B.

Well-known member
#5
If the installer failed at some point, running it again should pick up from the step that it failed on (if it's a step-based installer). However, at that point, no data will have been imported yet so I'm surprised you have the templates, etc unless it failed at a later point. If it failed later, then reattempting an install should allow it to pick up the data import and resolve the install issue.
It failed on template modifications because XFMG isn't installed -> https://xenforo.com/community/threa...ifications-for-non-existing-templates.134952/
 

Mike

XenForo developer
Staff member
#6
I'm going to call this as designed for the reasons mentioned. If we see that this is becoming a significant problem, then we would consider whether other actions are needed (though the likelihood there is that all we'd do is add specific handling to CLI add-on uninstallation to allow this case to be handled).