1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"No such file or directory" in configuration builder

Discussion in 'Installation, Upgrade, and Import Support' started by n0mDePlume, May 28, 2012.

  1. n0mDePlume

    n0mDePlume Member

    I'm in the Verify Configuration step of the install, setting the database parameters. When configuration builder tries to connect to the database I get the error:



    I'm pretty sure the mysql parameters are correct because they're the same ones as in my VB3 config.php. I tried connecting to existing and non-existing databases.

    What I SUSPECT is happening is that Xenforo is trying to do something not supported by my PHP configuration. Trying to execute a program that doesn't exist, or something like that. VB3 works fine, though.

    Unfortunately I can't figure out how to get any more detail than this error message. Does anyone have any suggestions?

    Thanks.
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  3. n0mDePlume

    n0mDePlume Member

    Looks like my sock file was set for mysql but not mysqli, thanks.

    Now here's something odd... the install only worked for me on the second try, if the xenforo database already existed.

    On the first try, it installed the database (I confirmed by checking that tables had been populated with the values from MySql.php), then aborted with the error "You cannot proceed unless all XenForo database tables are removed."

    To me this looks like step 2 of the install was somehow being called twice if the database is empty or something (because the error check occurs before the database is actually populated).

    When I tried a second install, it gave me a check box to remove the database, and everything was happy.
     
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Probably a fluke given the error message and repeated install attempts. Obviously the install creates the tables, and it will give you an error if the tables already exist. I wouldn't worry about it.
     

Share This Page