1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 No responsive

Discussion in 'Troubleshooting and Problems' started by AndreaMarucci, Nov 4, 2013.

  1. AndreaMarucci

    AndreaMarucci Well-Known Member

    Hello. Just upgraded to 1.2.2 but my forum is not resposive at all. I've read everything, I think, about this issue but surely there's something left out from the soft responsive addon I've installed before (and now deleted).

    This is what happen if I reduce the width of my browser window. The sidebar is always there.

    Can someone help?

    Schermata 2013-11-04 alle 16.45.05.png
  2. Jeremy

    Jeremy Well-Known Member

    Can you reproduce this on a default style with add-ons disabled?
  3. Qwest

    Qwest Member

    Did you enable responsive it in the admin panel?
  4. AndreaMarucci

    AndreaMarucci Well-Known Member

    Not it's seems working since I've merged the PAGE CONTAINER template. The only doubt I've is that I've these values in style property Page Width Controller. Are they correct or they're left from the soft responsive style I've installed before? I mean the ones in the Miscellaneous section...

    Schermata 2013-11-04 alle 16.55.17.png
  5. Jeremy

    Jeremy Well-Known Member

    You can't set a width if you want responsive. You can only set max-width. And there is a responsive flag, do an acp search for enableResponsive.
  6. AndreaMarucci

    AndreaMarucci Well-Known Member

    Responsive is enabled. If you want to try the forum is at http://forum.kog.it

    Do you mean that I've to delete all the things in that box?
  7. AndreaMarucci

    AndreaMarucci Well-Known Member

    Here it is

    Schermata 2013-11-04 alle 17.08.35.png
  8. Brogan

    Brogan XenForo Moderator Staff Member

  9. AndreaMarucci

    AndreaMarucci Well-Known Member

    So you mean that I've to make _width:976 to 800?
  10. Brogan

    Brogan XenForo Moderator Staff Member

    If you explicitly set a width then the style won't be responsive.

    Use max-width.
  11. AndreaMarucci

    AndreaMarucci Well-Known Member

    You're right Brogan. Problem is that I don't know how to use max-width

    You mean I've to put _width: max-width; instead of _width: 976px;
  12. Jeremy

    Jeremy Well-Known Member

    No, you put max-width: 976px
  13. Shelley

    Shelley Well-Known Member

    Have you tried setting _width: 976px; and adjust it to max-width: 976px; ?

    By Jeremy​
    Last edited: Nov 4, 2013
    Jeremy likes this.
  14. AndreaMarucci

    AndreaMarucci Well-Known Member

    Thanks Shelley. Now my forum seems to be working. Just asking yself if these values are correct or not...

Share This Page